Lightburn stops during progress

Hello together,

i built a mpcnc with an open cnc shield that runs with an Arduino Nano and GRBL1.1h on it.

My problem is, that lightburn stops during the project without a fault.
Sometimes the laser stays on depending of it current job.
It happens after seconds, minutes or 90% job done.
The console hold on the gcode or says

I used the search an tried following:

  • decrease speed and acceleration
  • set transfer mode to synchronous
  • reinstalled ch340-driver
  • reinstalled lighburn
  • tried another cable

Also what i noticed, if i step too fast, it freezes in “busy” until i stop it.
Im not sure if the problem is my controller, the driver or something else…

Thanks in advance, sry for my english and greetings


In the Console window in LightBurn there’s a switch on the right that offers ‘Show All’

Some CNC devices offer fairly elaborate reporting. While great for live position tracking with slower machining operations it can be a bit of a load for a Nano with a laser. The GRBL gnea project sets the default for reporting to a minimum.

Do you have the Machine Settings you selected for your build?

The 8 none and 1 at the top might be a popular choice.
The $10 setting may be of interest.

There’s a slim chance that the high current Power Supply for the drive motors is injecting noise into the serial communication. It may be worth testing the CNC controller with USB serial power only to verify that it communicates easily.

Looking forward to knowing more about your setup. You’re welcome to post Pics here by dragging them into the compose / reply / edit box.

Hi JohnJohn,

thanks for your reply. “Show all” was always off until the errors. I activated to look if my nano say whats wrong.
Atteched the setup of my laser.

My cables are all shielded, but its not perfect.



In the Console window in LightBurn please enter the following command:
followed by enter.

Please retest and report back. I am very optimistic as I see no data loss in your screen captures.

Ok. Before yout tip, I made a stresstest and it stopped after about 50 minutes with this in the console:

After that, changing $10 didnt work.

Now i restartet the controller and lightburn but it doesnt help.

I also wondering, i cannot set my home postion to 0,0.
I have to type G92 X0 Y0 Z0 in the console.

The first image was shot before changing…
Ich checked it twice, $10 = 1.

The first project lasts really long. After the first abort it isnt possible to do a new one.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.