Lightburn – Strange number issue.

Hi all,

I have just started learning Lightburn to help my parents learn how to laser engrave. What a fantastic piece of software. I am really enjoying learning it.

I have one small issue and I would be very grateful if anyone could advise me on it.

I started to draw numbered discs before our laser engraver arrived so I could learn how Lightburn works. The numbers are engraved (fill) and the discs are subsequently cut (line).

When I added the laser engraver in Lightburn (Aeon Laser – Ruida), the discs I had previously drawn were upside down. I am guessing this is due to the top right-hand origin, the default settings must have been bottom left before I added the machine. No problem, a simple 180 degree rotate fixed the issue (photo attached). The discs look perfect and cut/engrave perfectly. However, when I save the file and reopen it, the numbers have rotated and are in a different position.

The only way I have found to get them back in the correct position is to delete the laser engraver device, close the program and re-open the file in Lightburn, then add the machine back in Lightburn. If I save, then close and re-open the file after completing the job, the same problem occurs again.

Obviously, I could re-draw the numbers, in the correct location now the machine is configured in the software and it will probably keep the correct location but it would save a lot of time if I can somehow fix this issue.

It feels like there is a clash between the default Lightburn work area and the work area which I gain access to after adding the laser. I notice the snap to grid (1mm increments) doesn’t work properly on my file after adding the laser machine. It will snap in the middle of the 1mm increments on one of the axis (photo attached). I’m not sure if this is a clue.

Thank you in advance for any advice you can provide. I really appreciate it.

Rich

Change the origin to the wrong corner. Load the file and things should be upright. Change the origin to the correct corner. Select everything, then press > twice to rotate 180 degrees, and save it again.

Hi Oz

Thank you very much for your reply. I’m sorry I can’t seem to get it to work (i’m probably doing something wrong). It’s almost as if the numbers are linked to a different origin to the shapes/lines.

Step 1. This is the file when I load it in Lightburn with the Ruida engraver set up (origin top right hand corner):

Step 2. I then change the origin to the bottom left hand corner in the laser engraver settings in Lightburn.

.

Step 3. I then change the origin to the correct corner in the laser engraver settings in Lightburn (top right).

.

Step 4. I then select everything and rotate it by 180 degrees but it doesn’t seem to work. Sorry if I have done something wrong.

.

The only way I can get it to align properly, as in the first screenshot in my original post, is to delete the laser engraver in Lightburn and then open the original file (the same file opened in step 1). I can then add the laser engraver settings back in Lightburn (Ruida, origin top right) while the file is still open. It looks correct, engraves and cuts perfectly but as soon as I save, close and reopen the file (with the laser engraver still set up in Lightburn) I get the strange text alignment issue (please see step one screenshot to see the issue).

I have tried to upload my Lightburn disc file but it says new forum users can’t add attachments.

If you have any suggestions I would be very grateful.

Thank you

Rich

Post the file here and I’ll have a look. Text is weird because it tries to load “upright” regardless of the origin setting. You need to change the origin setting, THEN load the file, then change it back.

Thanks Oz, I have just tried your suggestion. After completing those three steps the file looks fine and will cut and engrave perfectly however when I try to save the file, close and then re-open it, the same thing happens where the text loads upside down for some strange reason. Here is a link to the file (sorry it won’t let me post a link directly because I am a new user):

Thank you for your help with this.