Lightburn to Lenovo laptop problem

Hi, been trying to set up , the laptop I have should be ok but may need settings tweaked . First issue is that when I try to connect the atomstack a5 to lightburn I’m getting msg that port unable to supply enough power, is this due to a setting, the ports on the laptop are fine and working

Some laptops may have ports that function but the device connected to them may need more power than they can supply. USB as a protocol is generally pretty safe and negotiates lower current draw, but not all devices do.

You may need to / want to check other USB ports on your computer, your power plan in Windows, and worst case look into getting an externally powered hub.

Ok thank you I will try that out

Ok bit of an update I tried all the settings suggested to no avail, bought an external powered usb port 5v 10w max . And the atomstack still won’t connect do I need more power. Please help. Thanks in advance

Are you still getting the message you initially saw? Can you share a screenshot of any warnings or messages your computer or LightBurn are showing when trying to use the laser?

Hi, thanks for the reply, I had bought an external powered usb port which had took the warning message away but still no connection the picture I’ve sent just taken with the atomstack straight into the laptop usb, I’ve had the power plan sorted , drivers downloaded, etc , I think the problem may be that the power supply I had bought was only 10w max, so I have ordered a more suitable supply which will do up to 37w, I’m assuming I’m right thinking this way as my laser is the atomstack a5 20w, please let me know your thoughts on this. Thank you

Sorry laptop is a lenova v14-11L running Windows 11 thanks

Looking at your screenshot, if the externally powered hub resolved that warning pop-up from Windows, you’re still one step closer to it functioning correctly! Before you go out and drop more money on a new laptop power supply, we can try to troubleshoot the software portion more and get you up and running.

Under the pop-up from Windows, there’s usually laser connection information, including “Port” and “Device”.


In yours, can you share what’s listed? “Waiting on connection” in your screenshot usually means LightBurn doesn’t see any devices that are valid, but given that Windows was seeing more power requested by the device than the laptop’s port can supply, LightBurn may not have been able to see it.


1 Like

It’s as picture and saying at bottom type commands here ?

Also tried laser web no option for port on that either

If you open Device Manager what do you see under the USB section?

Control Panel >> Device Manager >> Universal Serial Bus Controllers/Devices

All signs point to this being a USB short to ground that is drawing far too much current and causing the port to shut off.

1 Like

Hi, this is what is displayed if it helps, no mention of any other drivers that were supposed to be downloaded,

Think I might be a bit further but still won’t connect

Would it possibly be an issue with the atomstack software being incompatible with windows 11. It’s an atomstack a5 m 20w. Thanks

I also suspect USB power, shorted to ground.

As a test, If you’re so inclined, please disconnect everything from the Atomstack control board and attempt to connect just the bare controller to the computer with the USB cable. I don’t know how accessible the board is for Service. It may also be prudent to inspect the cables and wires for mechanical damage.

Your Atomstack may have limit switches and it may not. Some aftermarket kits are available. A limit switch when damaged or installed incorrectly across three pins may be responsible for shorting Microcontroller (USB supplied) power to ground.

The Stepper motor drivers should not be relying on the USB power. Laser power should also not be a problem. These wires and components should not be impacting the USB port. Is there a small cooling fan on the Atomstack board?

The little circuit boards that plug in are the Motor Drivers. They have Microcontroller (USB Supplied) power and High Current power for the motors.
If these little boards unplug from your Atomstack - Again, If you’re so inclined - with everything powered down - carefully unplug them for testing. A short in the little driver board could be responsible for overloading the USB port.

My two Lenovo Laptops both power up diode laser controllers for communication just fine.

Once the board is disconnected, feel free to test other USB ports and cables with your computer as well. I hope something is observable in your pursuits here.

Problem sorted, after all this it was in the initial install, near the start of the light burn install not all the drivers had been ticked when prompted, uninstalled light burn re installed with those ticked straight in and sorted. Thanks for the input

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.