Lightburn unable to find Monport

I purchased a Lightburn compatible Monport 40. No matter what I’ve tried, Lightburn is unable to find my engraver. Monport told me to download LaserDRW K40 Whisperer. I downloaded the program but am unable to use it as I don’t have a USB key. I’ve tried using the program to find my laser but I don’t think it can find it.

Occasionally, laser engraver suppliers simply don’t bundle adequate ‘getting started’ instructions.

I have no Monport documentation available but i’d be happy to add to our internal reference pages if you’d like to share anything they provided.

Barring that, a really good close digital picture of the control board or the model number of the controller if it’s in a sealed box may clue us into which communications drivers may be needed.

Sometimes the best clue is a number like CH340 or CH341 (or CP2102) on one of the smaller chips on the board. That may be all that is needed to get you unstuck.

What chips am I looking for? I specifically purchased the Lightburn compatible Monport not a LaserDRW or K40 Whisperer version. Is there a back door thing of getting Lightburn to recognize my engraver? Are there any other settings I can use? Is there a specific file I can install in Lightburn?

Somewhere it has a usb port, the communications chip should be near that… Can’t see it in the 2nd photo, but it should be around the bottom left near the connection. Near the 470 object.


I’m hoping a driver will resolve any communications issues you have but here’s a couple of quick things.

Re: pic #2. Bottom Left. This may be a model name for the controller:

Re: Pic #2 Bottom Right. The diagonal arrows point at what I believe are your USB communication cable on the right (I was wrong - This is +24V Power supply) and some type of communication port (offline controller port) on the left. The more vertical arrows show the oval metal can for a crystal oscillator and what is most likely the microcontroller chip. I don’t see a separate chip on this side of the board for the communications.

The number marked on that chip might give me the driver info. (maybe)

Generally i’m looking for a smaller chip with fewer pins or a rectangular chip with two rows of pins. It may be built into the processor so I might find the driver with a clear read of the number on the chip. The datasheet for the processor may also recommend a serial chip worth trying.

Great Pic and this is a great start!

Should I assume there was no other documentation bundled with your Laser?

You can hope the driver is already present, or install two or three common drivers and hope for the best. At that point, jumping from Com Port to Com Port in the Laser window and waiting 5-10 seconds while watching the Console window, hoping the laser connects might be an option but I’d prefer to get closer before trying it.

Settings are usually available after we’re communicating. I’m not even fully sure what the controller is.

Ideally, we’ll get a really good idea what the driver should be and install it. The communication chip will also tell us the maximum communication speeds and a few other things. The FDTI chip (probably not here) has some voltage incompatibility issues when communicating with a Mac. (also doesn’t apply…)

Found the manual. It’s pretty Sparse.

You may want to contact Monport to confirm you received the correct machine.

This is a photo of one of my ESP32 development boards… You can see the driver on the right next to the usb connector…

This is a CP2102 type.


1 Like

Because of the ATmega328P processor listed in the Manual I’m beginning to think that it will be a CH340 or CH341 driver.

The Controller board was on sale for $60 USD. I ordered one. :slight_smile:

Here are two better pictures of certain components. None of which tells me anything.

I’m thinking that’s not it… a lot of horsepower for i/o…


I suggest going back to basics.

Can you confirm that the controller is detected by Windows?

Can you check Device Manager->Ports to see if a COM has been assigned to the laser? Or else, do you see a device with a question mark? This will tell you at least that Windows is recognizing the device. If you need have a question mark then please take a screenshot of Device Manager. That will indicate what driver you need. It’s almost certainly a CH34x serial device.

1 Like

Here is what I get when I plug in the engraver.
Device Descriptor Request Failed

That’s not good. How are you connected from the computer to the controller? If you’re going through a hub then try connecting directly.

Try these other remedies to see if you can get a descriptor:

  1. change USB port being connected to
  2. change cable
  3. remove any hubs
  4. test on another computer to see if the laser is detected there

This isn’t what I would expect if the issue was just the lack of a driver. I had thought that Windows shipped with the driver. Looks like you’re running Windows 11. Can you confirm?

I connect directly to my computer. I’m running Windows 11 home edition. My desktop is in my bedroom and have no way to hook up to it. I will see if there is anything I can try.

At least try to be able to swap cables and USB ports.

Try also to turn off power management on the USB ports. That may have an impact on USB function for your laptop.

I tried using my brothers computer and his is running windows 10. His recognizes it but it doesn’t show up in the USB configuration.

Does this mean I need a laptop running windows 10? I don’t know why my xTool can be run from my laptop and not the Monport.

Can you open the Ports node to see if a COM port has been assigned to the laser? Try disconnecting and reconnecting to confirm that the COM port is associated to the laser.

Can you double click the port to see if you can device driver information. Would like to confirm it’s a CH34X.

I didn’t realize you had an xTool. Those use CH34X serial controller so it’s likely not a driver issue.

Can you try connecting the xTool and confirming the port in Device Manager?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.