Lightburn update wont connect machine

I am using a JTech 7w laser on a Millright MegaV. Lightburn v9.16 connects automatically without any issues. I next upgraded directly to v9.19. That version will not connect to the machine at all. Updating to v9.20 did not help and the problem persisted. Reinstalling v9.16 allowed me to use the machine again.

I do not know if v9.17 or v9.18 works because I never tried those.

What is causing the updated versions to fail and how can I fix it? Thanks.

It seems that some controllers use what I would call “not a true port” of GRBL, and it appears this is one of them. The 9.16 version of LightBurn sent G0 to the controller to see if it was there before sending other commands.

A couple of our vendors complained that their machines, when starting up, would issue an error if a G0 command was sent before the controller was ready, and even though it was completely harmless, customers complained that there was an error, so it was changed to be just the equivalent of pressing ‘enter’ to get the controller to respond with ‘ok’. Every GRBL device I have here works like this - if you send it an empty line it just says ‘ok’, but apparently some devices don’t, so I’ll have to change how this works again.

I have the same equipment as Dan and have the exact same problem.
I uninstalled and reinstalled both lightburn and c++ with no success and went back to 9.16 as he did. Hope to see a fix soon. Lightburn is the best.

I tested a couple versions with software edits but none fixed the issue. Oz was working on it but I haven’t heard any update in a few weeks and for some reason I’m no longer able to reply to his messages. Have you found any other solutions?

Give this version a try?
https://drive.google.com/file/d/1i6ZLNsN4zb1ygli9bF58_u_Mm0ala2eU/view?usp=sharing

If it doesn’t connect, try changing the setting for ‘Enable DTR’ in the device settings. You may need to restart LightBurn for that setting to produce the required effect.

1 Like

My problem was probably mainly hardware. The MillRightCNC breakout board on top of the mega 2560 board was installed incorrectly. The pins on the left side ,if looking from the usb connection end, had all bypassed the sockets to inside. Amazingly the only thing that that disconnected was the pwm. Oz said that some changes he made to the software may have also made a difference. I can now connect with the 9.2 ver. Another thing I read is that usb cables can be charging and data cables. You need the data version.

Success. The machine connected to this version. DTR was disabled when it worked. I did not test it enabled. Thanks!

Enabled would likely fail - Arduino based devices use that signal to mean “reset the device”. Which is incredibly frustrating, because normal serial communication devices see that signal to mean, ‘The connected computer wants to talk to me’.

Thanks for the help. Will future versions contain the fix now or will I have to stick with what you sent?

This is a permanent fix and will be included in future releases.

I have switched computers and am having issues connecting with Lightburn 9.2 again. However if I first connect with UGS , do nothing in UGS, and close UGS then restart Lightburn it will connect without problem. Any Ideas? DTR is not enabled.

Are you using the 0.9.20 public release version, or the build I linked above? The public release still has the DTR bug.

I believe it is the public release. I do have DTR off though.

Just tried DTR on and off. Would not connect either way. But still connects with no problem after I have connected with USG. I do have to connect with USG not just load it.

I installed the 9.21 version. I had to stop com surrogate process to continue with install. After install Lightburn started and connected without problem. However, I quit Lightburn and restarted and it would not connect again as before. Again after connecting with UGS Lightburn connects with no problem. I have tried again with DTR on an off with no differance.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.