Lightburn uses lowest camera resolution possible

I’m trying to setup a 5MP 120° FF USB camera with Lightburn. The built-in chip of the cam is a OV5648 according to the seller.
When I use the camera in other software, it is possible to run at a resolution of 2592x1944. In Lightburn the resolution is way lower.

My best guess is that the resolution of 2592x1944 is not supported by Lightburn?

Happy for any troubleshooting tips :slight_smile:

Here is the image made with external software:
Webcamtests Saved Image - Copy

And here it is from Lightburn:

Here are the camera settings in Lightburn:
Lightburn Settings

I have been fighting this same issue.

1 Like

I used to detect the possible resolutions for this camera. It only supports 640x480 and 2592x1944.

I tested it with another camera and it works with higher resolution. So the problem lies in the way Lightburn handles my camera.

@gentzleon Did you solve the issue or did you find a workaround?

Are you certain that it’s not being captured at higher resolution? When you did the lens calibration, what was the reported resolution?

I suspect things would look far worse if it was capturing at 640x480. Note that the overlay that you’re showing is a small area of the overall captured image.

Also, have you run the camera alignment process? Curious why the overlay is so zoomed in.

I cropped the images to make the problem clear. Below you find the full-size images.

So far I was not able to complete the full camera lens calibration and used the preset 120° calibration.
The pattern does not get recognized. I thought this was because of the low resolution, but now that you mention it the capturing window says 2592x1944:

I glued the pattern on a piece of wood to have a flat surface. It looks like it is well lit.
The camera alignment calibration was finished but difficult because of the resolution.

Here is my setup:

And the full size images:

The honeycomb pattern may be confusing the detection. Try covering the honeycomb. You may also want to enable the “Honeycomb check enabled” button.

It’s also possible that the calibration card is on the small side.

Try holding the card by hand at different locations to coax a successful capture.

Failing that, I’d suggest trying the lens calibration with the camera off the laser. You want very soft even lighting if possible.

Thanks for the suggestions @berainlb

I did some testing yesterday: Untitled video - Create and share your videos with Clipchamp
I hid the honeycomb, mounted a ring light around the camera and tested different light settings while calibrating. I think something is not working correctly, because I need to capture a lot of images before one falls into acceptable range.
At the end I managed to complete the calibration process together with the camera alignment (I know I can improve this step a lot, but I want to fix one issue at a time). The outcome is still a really low resolution. Maybe this is just the best result regarding the resolution I can get?

I will test out your suggestion with the camera off the laser next.

You could attempt to use the “Default Capture System” to see if that results in something better. LightBurn does lens distortion, perspective correction and cropping to get the overlay so that will result in perceived quality loss but not sure if that accounts for the full difference.

I tried the calibration with moving the camera without any remarkable difference.

However, the change to “Default Capture System” changed my results. Calibration was easier and resolution at the end looked way better.
Only problem I have now is that only 1920x1080px are used. The image looks cropped.
In the video you can see the full resolution at the start (captured with external software) and during the calibration only a small cropped part of it. At the end my previously printed alignment points were not visible.

Is there a possibility to manually change the resolution of the “Default Capture System”?

No. Not that I’m aware of that I’ve ever seen discussed.

The image does look cropped but I don’t think the resolution is necessarily the issue.

Try disconnecting the camera and restarting the computer. If that doesn’t work, try plugging into a different port on your computer, preferably something that accommodates USB3. If you’re using a hub, remove that from the equation. Are you using the cable that came with the camera? If not, try a different cable.

I tried restarting, using another USB cable as well as different ports. I can also switch between Lightburn and other software and back and the resolutions stay the same - low in Lightburn and high everywhere else.

I checked another two external softwares - Windows Camera and AMCAP. Both can take photos with the high resolution. However the video stream is only available in max 1080p.

Windows Camera:


When you capture video with the other applications does the image get cropped? I would expect similar cropping as the photo but only with reduced resolution.

You are correct, If I capture it with 1920x1080 with other software, it gets cropped the same way.

As a workaround I tried using OBS as a virtual camera solution. I can create a stream in 2592x1944, but the virtual camera does not work with LightBurn, as in other threads already discussed.

I’d suggest reviewing the Topics that do this for LightBurn Bridge. People have been able to get virtual cameras to work in those cases.

I finally got it working with the workaround in OBS. It is neccessary to use a version from 2019, otherwise Lightburn does not accept the camera.
Here is the solution:

  1. Download and install OBS Studio 24.0.3 from here: Releases · obsproject/obs-studio · GitHub
  2. Download and install OBS VirtualCam 2.0.4 from here: Releases · CatxFish/obs-virtual-cam · GitHub
  3. Configure OBS Studio to create a virtual camera and start it (you can also set things like brightness, contrast & exposure in OBS Studio)

  4. Apply Setting “Default Camera System” in Lightburn
  5. Camera “OBS-Camera” is usable in Lightburn

In summary I had two problems using Lightburn

  • “Custom Camera System” does not apply the resolution 2592x1944 when updating the overview. Calibrating the camera lens works with this resolution for some reason.
  • “Default Camera System” does not use the highest resolution available (uses 1920x1080 when 2592x1944 is available)

My workaround consists of using an outdated 3rd party software. So I hope this will be fixed in a future update.

Thanks @berainlb for the troubleshooting help! Now I can get back to lasering :slight_smile:


You may want to try using “Custom Camera System” with the virtual camera. That will make additional controls available.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.