Lightburn versions later than wont work with my Black & Red TopWisdom laser

Hi folks - I just upgraded my Lightburn license today to get the latest version going and discovered than though I can move the laser head around etc, when I send files to my laser, it never sends and doesn’t start.

I’m running this on a MacBook Air running macOS 10.13.6 (the latest it can run) and connecting to my laser via USB.

So I went back to 0.9.04 (that I have been happily using) and it works fine. I can send all of my jobs and they cut fine.

I then decided to downloaded a few other versions, and tried those, and… shows a “sending bytes” window, but never starts a job and the controller doesn’t show the image of the file.

I tried and like, it doesn’t show any sending UI and nothing appears on the laser screen or starts on the machine.

But works 100% reliably. I’ve been through the settings. I’ve manually re-setup the laser - and it sees it fine… as I said, I can move the laser head around with the laser positioning tool, but I just cant send it any jobs.

Any ideas?

Unexpected Maker

No takers on this one?

The fact that it works in and versions previous to that, but not in later versions - so something must have changed in the codebase around that time - and that’s not something I can dig into myself.

Unexpected Maker

What is the model of TopWisdom controller in your laser?

Sorry, forgot to add that - just the standard TL -410C

I’m running FW version V.L017.101 and I did notice there’s a newer V.L017.110 version (from 2021) on Top Wisdoms website, but I’m reluctant to update FW on this when it’s working fine… just not with newer Lightburn versions.

I’ll update it if it’s recommended by Oz - but prefer not to brick my machine trying to solve this when it could be something simple I’ve overlooked.

Is there really no one else with a TL -410C experiencing this?

Though I’m very happy to be paying upgrade fees for my license, so far I’ve paid twice and not been able to upgrade to any version beyond0.9.0.4 - what I was previously using.

I’d love to be able to use some of the newer Lightburn features.


@LightBurn Any chance this can get looked at, or at least get some feedback on what I can try from my side to get this working? Or to give you more info to work with?


@SeonR, thank you for your patience. In a message from Oz, he mentioned that it’s possible that the TopWisdom controller might be similarly affected by the FTDI issues we’ve seen with Ruida - same driver.

Please have a look at this and let us know if installing a newer driver helps.

Hi, sorry for the delay in replying @Rick - I just had a chance to look at my laser Mac and there were no FTDI drivers on there - so this is not a solution to my issue in latest Lightburn :frowning:

Are you saying you have connected to your TopWisdom previously via USB but not using FTDI driver?

That’s correct - never been an FTDI 3rd party driver on here - and as I mentioned, newer versions of the software allow me to do “some things” - like I can move the laser head around with the position tool - but I just cant send any projects to the laser to do any cutting :frowning:

Message from Oz:

Apple’s supplied driver doesn’t do hardware handshaking correctly. If he goes to the FTDI website and grabs the VCP (virtual COM port) driver for his version of MacOS it’ll likely behave again.

VCP Drivers - FTDI

1 Like

Ok I’ll give that a shot, thanks :slight_smile:

Ok, interesting - new driver installed (well, super old driver, but that’s ok) and a reboot and now and onwards (tried up to works properly… but… and below wont connect at all anymore… even less functionality than I got from newer LB versions without FTDI drivers :wink:

Just pointing this out for reference :slight_smile: I’m super glad to be up and running now with the latest LB versions and hopefully wont see a need to revert to an older LB version anymore.

Thanks @Rick and @LightBurn !

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.