Lightburn will not open on my MacOS Ventura 13.6.6 no error messages

Hello, I installed LightBurn for the first time yesterday on my Mac desktop OS 13.6.6. Installation appeared to go well. I can see Lightburn in my Applications folder. The first time I clicked on it to launch it I got a message about trusting programs from the internet. I clicked OK to open, but the icon jumped up twice in my icon bar and thats it, program never opened. Ive tried deleting it and re-downloading and installing again but it does the same thing. I just cant get it to open. it just sits there. Latest forum messages on this topic that I can find are from 2021-2022. Help please and thank you! I just tried to download and install a previous version (1.4) and it installed and opened correctly. Does the latest version (1.5) have a Mac bug?

Nothing reported as you describe, no. We are about to release 1.6.00 in the next hour or so if all goes as expected. :slight_smile: I might suggest giving that a go once we do, and let us know how you get on. This is also worth review:

Are you running an x64 or ARM based Mac? If you’re running ARM then you’ll need to make sure that Rosetta is installed and working correctly.


I’m not sure but I don’t think it is x64. How can I find out? Also, I don’t know what ARM or Rosetta is. Thank you.

I will try to run 1.6 later today and reply with an update. Thanks for your quick reply!

ARM and x64 describe different CPU architectures. Apple have shifted away from x64 to ARM based processors that they refer to as Apple Silicon (M1, M2, M3, etc.). Rosetta 2 is a translation layer that allows programs written for x64 to be run on the ARM based processors.

Take a look here for how you can check what you’re running and for more general information about this:
How To Tell If A macOS App Uses Intel Or ARM - AppleToolBox

Note that typically MacOS would auto-detect the presence of an x64 application and automatically install Rosetta 2 but that doesn’t always work.

I uninstalled 1.4 which was working and installed 1.6 but it did the same thing as 1.5. When I tried to launch it just bounced the icon 3 times and then nothing. Thank for the help so far, but nothing but installing 1.4 has worked.

1 Like

Long shot, but if you still have 1.6 installed maybe you could try this:

To view your Mac system logs, launch the Console app. You can launch it with Spotlight search by pressing Command+Space, typing “Console,” and then pressing Enter. You’ll also find it at Finder > Applications > Utilities > Console.
Will look something like this

Now launch lightburn again
Then in the console do a reload and see if the timestap can show any error lightburn related.

Could need to drill also into “user reports” zone.

Bit investigative, but if you have the time could help greatly.

1 Like

Here are my hardware specs:
| Model Name:|iMac|
| Model Identifier:|iMac18,3|
| Processor Name:|Quad-Core Intel Core i7|
| Processor Speed:|4.2 GHz|
| Number of Processors:|1|
| Total Number of Cores:|4|
| L2 Cache (per Core):|256 KB|
| L3 Cache:|8 MB|
| Hyper-Threading Technology:|Enabled|
| Memory:|40 GB|
| System Firmware Version:|526.|

More info from system Settings:
Applications / Lightburn (1.4):


Obtained from: Identified Developer
Last Modified: 12/13/23, 4:40 PM
Kind: Intel
Signed by: Developer ID Application: LightBurn Software LLC (UWZQ3LL82C), Developer ID Certification Authority, Apple Root CA
Location: /Applications/
Get Info String: Created by Qt/QMake

Im not sure if this info helps, but it seems I have an Intel processor and the software (at least v1.4) is also Intel (Kind).

Im not sure if this is helpful or not…

Lightburn Log.txt (98.0 KB)

Have you tried rebooting your computer recently? Curious if there’s something in memory that’s potentially causing an issue.

Yes, I did a complete shut down and restart and it didn’t fix the issue.

Okay, I solved the mystery why LightBurn 1.6 would not open. I paused my virus scanning software and re-installed 1.6 and it opened and works fine now. Thank you to all that responded with help. Cheers!


I paused my virus software and re-installed 1.6 and it works fine now. Thank you for your help!

Thank you for this update. Fantastic news. :slight_smile:

Out of curiosity David - and because we always get the - " but macOs dont need antivirus" when we ask :smiley:
What Antivirus/Security software are you running on your MacOs?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.