Lightburn with Eleksmana v5.2 on Kwonshop Clone CNC


(Gerard Tonno) #1

Assistance needed, please!

About 6 months ago, I purchased an Eleksmaker knockoff because I wanted a larger workspace than what Eleksmaker offers. I purchased the Kwonshop (50 X 65mm – X&Y respectively), without a laser, and have since added an Endurance 10 Watt laser.

Initially, I downloaded demos of both T-2 and Lightburn, and with the originally supplied controller (an Eleksmaker Mana SE Clone). I couldn’t get the system to respond properly (I could move the axes, but not through the whole workspace unless manually jogging them nor in the correct direction. I wrote it off to the controller and the fact that it had no homing/limit switches. (now, I understand how I could have added limit switches myself, but at the time I thought it would just be easier to upgrade the controller, so I purchased the Eleksmana v5.2, with the homing switch daughter card kit. I figured this would greatly help with the issues I was having – NOT!

Fast forward to now:

Here are my current issues:

• Based upon a recommendation, I set out to use Lightburn to run the laser. I watched ALL the available videos, and downloaded and reviewed all the Lightburn documentation.

Due to the fact that I demoed it long ago, I paid for a license to unlock it. I thought I’d be good to go, but after spending the whole day yesterday tinkering, I’m no better off than when I started this process, and at this point, I’m thinking I may have wasted my money on the Lightburn license – pretty frustrating!

• I initially tried the original controller (updated to GRBL 1.1) with no joy!

• I then replaced it with the Eleksmana v5.2 board, without the limit switch daughter card. I figured, one step at a time, so let’s keep it simple and once I get it working correctly I’ll add the limit switches. (Controller came with GRBL 0.9i loaded, so I left it that way.)

• No matter what I try, I cannot get the axes to move throughout the whole work area properly.

  • I have tried resetting the origin to all 4 corners, using GRBL $3 command to invert X, Y, individually and/or both simultaneously. (This was done to get the axes to move in the correct direction, but while the Lightburn jog arrows may respond in the proper direction, when I enter coordinates to move to, the axes go the wrong way and crash into the rails.)
  • I have adjusted $100 & $101 X & Y step/mm, and have confirmed that when moving the axes 1 mm they actually move that amount, (This was done to assure the steppers are calibrated to move the correct amounts.)
  • I have adjusted $130 & $131 X & Y travel/mm to represent the work area size. (This was done in an attempt to get the software to use the whole work area, in addition to telling the Lightburn software the work area size, but at best it uses less than half the available work area.)

After all that, I was totally frustrated, as I still could not get things to respond properly, so I tried tinkering with T2, but there was a family issue I had to tend to so I decided to call it a night.

I know there has to be a way to get this handled, but thus far it has eluded me, and I’m sure at this point it’s a matter of some sort of misunderstanding I have with respect to function interpretation. I’m hoping that those of you in the group can assist me by shedding some light, PLEASE do!

Thanks VERY much!


(Rick James) #2

Post your current firmware version, lets pick one setup to start. Also post your $$ settings and folks can help from there.


(Oz) #3

When you say, “cannot get it to move through the whole work area” - this is a bit vague. Does it just not travel as far as it should? Do you get an error in LightBurn, or in the console window from the controller itself? Are you unable to move to certain areas of the workspace, but move freely everywhere else?

Specifics are helpful in tracking down issues like this, so the more of them you can provide, the easier it will be for us to home in on the problem.


(Gerard Tonno) #5

Here is the GRBL that is loaded and the current settings.


(Oz) #6

Ok, that’s a start - You’re using an old version of GRBL, so you’ll need to use the GRBL-M3 device in LightBurn. You also don’t have homing enabled, so prior to powering up the machine, move the head to the front left corner. When powered up, this will now be your origin, and that should allow LightBurn to move through the whole area.

Without limit switches or homing enabled, this is the only way to get some features of LightBurn to work. If you don’t do the manual homing, you should be able to use “Current Position” mode as the Start From setting, and just use the jog arrows to move. The click-to-position feature works in absolute coordinates, and those only work if the machine has been homed.


(system) closed #7

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.