Lightburn workspace not matching laser position

Hi everyone,
I’m new to laser engraving and new to lightburn and am looking for some advice/help if possible please.

I feel that i am up to speed with everything that i need to know to get started, however, no matter how hard i try, i cannot get the real position of the laser to match that of the workspace shown in Lightburn.

I will try my best to provide as much information as i possibly can as to what i have (kit) and things i’ve done so far, but any help will be greatly received and appreciated. thank you in advance to anyone kind enough to help.

Kit:
Sainsmart 3018 PROver - with 3040 extension kit and 5.5w diode laser installed.
Machine has homing switches and homing is completed automatically.

Steps already completed:
Lightburn Set up Wizard:
Located Laser
Set dimensions to (x axis) 300mm (y axis) 320mm.
Set origin to rear left (where the machine auto homes to)
Turned on “Auto home your laser on startup”

General settings:
Start from: Absolute co-ords

ISSUE:
When starting a job, the laser moves to a completely different part of the workspace to where the image is on the lightburn software workspace. NOTE: The dimensions of whatever i am trying to engrave appear to be exactly correct when i start the job, however it is always in the wrong place on the machine.
The thing that has underlined the issue for me is when i home the machine, and then use the “Set laser position by clicking on the page” - I click on the dead centre of the page in lightburn but for some reason, the laser goes off to a completely different position on the right hand side of the workspace. Please see below link to a video of exactly what the machine is doing showing the position where the laser rests in relation to where i click on the workspace.

https://youtu.be/HIW6hXOfsJM

If there is any further information needed, please let me know and i’ll be happy to try and provide clearer information of the issue.

Regards,
James

What position do you get after homing when selecting the ‘Get Position’ button at the top-left of the ‘Move’ tab? What does this read after repeating the test you show, navigation to center?

Share your $$ settings for review.

This is worth review.

Hi Rick,
The position co-ordinates look right for the position of the laser once it comes to rest - albeit out of place.
I will take a screenshot of them when i’m home later on today, along with the $$ settings for review.

I have been through the article that you shared here, however nothing seems to have any affect.

Thank you for taking the time to try and help, really appreciated.

James

Below are the details on the machine as requested:

When turning the machine on, it auto homes. At the "Home point, it shows as:
x -48 y 262 z 10.10

When moving to the “middle” of the bed as per the video the co ordinates are:

X 151 Y 170 Z 10.10

Below are both my $# and $$ settings.

$#

[G54:48.500,-262.000,-10.100]

[G55:0.000,0.000,0.000]

[G56:0.000,0.000,0.000]

[G57:0.000,0.000,0.000]

[G58:0.000,0.000,0.000]

[G59:0.000,0.000,0.000]

[G28:0.000,0.000,0.000]

[G30:0.000,0.000,0.000]

[G92:0.000,0.000,0.000]

[TLO:0.000]

[PRB:0.000,0.000,0.000:0]

ok

ok

$$

$0=10

$1=25

$2=2

$3=2

$4=0

$5=0

$6=0

$10=0

$11=0.010

$12=0.002

$13=0

$20=0

$21=1

$22=1

$23=1

$24=25.000

$25=500.000

$26=250

$27=1.000

$30=255

$31=0

$32=1

$100=800.000

$101=800.000

$102=800.000

$110=2000.000

$111=2000.000

$112=600.000

$120=10.000

$121=10.000

$122=10.000

$130=300.000

$131=320.000

$132=100.000

ok

…Could my G54 be the issue here? i think that’s offsets?

Thanks again.
James

Hi Rick,

Just want to say thank you for your efforts to help me.

Figured out in the end that i had an offset programmed into the board somehow. I altered the G54 coordinates and all is well with the world!

Thanks again for your help.

1 Like