Ligtburn lagging and spooling with windows 10

I"ve been running Lightburn for over a year on this 17 year old Asus Sonic Master laptop with out issues. A few days ago after renewing software I started to have problems with a lot of lag. I defragged the hard drive, which was a mess, then ran a system file check which was good.
’ also uninstalled and reinstalled the software. Lightburn is the only software on this computer other the the garbage that windows has. The problem seems to be messing with the white painted tiles I’m working on. I’ve run this file over 30+ times with little problem but since the lag started it has been hit or miss to get a useable part. When I watch the system monitor I often see the Disk monitor peg. How does computer problem effect the burn? Is it time the put the old Asus to rest? * do have a Amazon refurb laptop coming Sunday. Need to ad this is an Ortur Laser Master 2 Pro.
Thank you!

Maybe do a memory check. That laptop is like 90 in human years.

LightBurn continuously dribbles G-Code commands to the laser controller, so a long pause in the proceedings stalls the laser in one spot and will, at least, overburn that place.

If you were engraving plywood, that spot would soon have a merry little fire, with the laser head and all its plastic parts parked directly above it.

FWIW, this is why the good folks at LightBurn stubbornly refuse to add end-of-job features allowing users to wander away from the machine while it’s running. Everybody says they’ll be careful, but nobody can pay attention to two things at once.

I’ll do that just for my own curiosity. Even if it is bad I’m not putting any money into this thing. I like the comparison, 90 years. :laughing:

, I thought the G code was dumped to the controller, not sure how computer issues could effect the end result. . I only know I have a pile of unusable tile coasters sitting in the trash, so far it’s a 50/50 shot as to whether the part is good or not. I’ve not had this happen before. The lags are in the interface not in the laser. Every time I try to modify any settings there is a 5+ second delay usually with a little spinner. The laser actually stopped last night mid burn, with no faults.

While using the computer, turn off (disconnect) your WiFi and see if the performance improves.

If it does, there are two possibilities, [1] your Wifi network is very busy (maybe hacked), or [2] a virus on your machine is staying very busy.

If it does not, the problem is internal to your machine. A memory error or bad hard drive sector are two possibilities.

That’s interesting, I checked the task manager, with the laser off Lightburn is bouncing over 600mb to the memory even with the Wi-Fi off. The laptop has only 4gb of memory with 2.5 in use when idle and no WiFi.

I turned the Wi-Fi off and stopped Microsoft Edge, laser is back to normal burning perfect parts with no problems. All lagging has stopped. Now I’m really puzzled! What the heck is going on!
Thanks for you input!

That’s incorrect, at least for the 8-bit microcontroller versions, because they simply don’t have room for more than a hundred-ish characters of G-Code.

This section of the GRBL doc describes what’s going on:

The larger 32-bit microcontrollers have more buffer space, but not enough for an entire image engraving program.

So, basically, anything that interferes with the PC’s ability to dribble G-Code characters to the laser will eventually cause the microcontroller buffer to empty out, so it must sit there waiting.

Thanks for the info. All I do know is that I turned the Wi-Fi off and stopped all unnessary processes that were spiking the disk and CPU, I have run 4 perfect parts. Could not do that last night! Lightburn has very little lag when any changes are made. Everything in the task manager looks good. Now I have to figure out why and what is going on over WiFi. I am still getting a brief Not responding when I close Lightburn

Yeah, I wonder what the problem is…?

I use Chrome and occasionally Firefox. Edge is constantly talking to the MS servers.

You might turn off Windows automatic updates too… I had to do that for my CNC router to process tons of code for circular interpolation.

Thanks, good suggestion! I have that off. Right now I’m keeping the Wi-Fi off too since this old laptop is dedicated to Lightburn only.
I think it was some malware that was screwing the limited resources of this machine.

That was one part of the part of the problem,Edge eats up a lot of resources. That combine with some malware was putting the laptop into overdrive.

I did pick up an Amazon refurb laptop for $150, Dell latitude that is dedicated to the laser, It came in-today, now all seems to going smoothly.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.