Ligthburn and Curve Compatability with new Jackpot Controller from V1 Engineering

I am having an issue with Lightburn and the GRBL output to generate a circle, curve, or any item that requires a form of a curve in my cut.

If a square or any item containing straight lines is generated and output to the GBRL laser cuts correctly.

If a circle or any item containing curved lines is generated and output to the GBRL laser, the laser moves to the start position, starts the circle or curved item for a split second then stops and I get this error code

Starting stream
Layer C02
Unsupported or invalid g-code command found in block.
On or near line 2:
Job halted
Stream completed in 0:00

Any idea as to what could be causing this error and stopping the process ?


Can you go to File->Save Gcode and save with .txt extension and upload that file here? Will review to see what’s causing the issue.

This is the file that was generated for the shape of a circle that stops and generates the error code. This would be the same for any shape that would have a curve to it. as far as the curved shape it does not matter if it is drawn in lightburn or imported from a dxf file, the process will stop and the error code indicated.

; LightBurn 1.4.01
; GRBL device profile, absolute coords
; Bounds: X10.82 Y13.41 to X44.68 Y45.6
G00 G17 G40 G21 G54
; Cut @ 2000 mm/min, 10% power
G0 X18.971Y15.741
; Layer C06
G1 X18.284Y16.159S100F2000
G1 X17.62Y16.608
G1 X16.981Y17.086
G1 X16.366Y17.592
G1 X15.779Y18.125
G1 X15.218Y18.684
G1 X14.686Y19.268
G1 X14.183Y19.876
G1 X13.711Y20.507
G1 X13.271Y21.16
G1 X12.863Y21.834
G1 X12.489Y22.528
G1 X12.15Y23.242
G1 X11.847Y23.972
G1 X11.581Y24.72
G1 X11.353Y25.484
G1 X11.164Y26.263
G1 X11.015Y27.056
G1 X10.907Y27.861
G1 X10.842Y28.679
G1 X10.82Y29.507
G1 X10.842Y30.335
G1 X10.907Y31.153
G1 X11.015Y31.958
G1 X11.164Y32.751
G1 X11.353Y33.53
G1 X11.581Y34.294
G1 X11.847Y35.042
G1 X12.15Y35.773
G1 X12.489Y36.486
G1 X12.863Y37.18
G1 X13.271Y37.854
G1 X13.711Y38.507
G1 X14.183Y39.138
G1 X14.686Y39.746
G1 X15.218Y40.33
G1 X15.779Y40.889
G1 X16.366Y41.422
G1 X16.981Y41.928
G1 X17.62Y42.406
G1 X18.284Y42.855
G1 X18.971Y43.274
G1 X19.68Y43.661
G1 X20.41Y44.017
G1 X21.16Y44.339
G1 X21.929Y44.627
G1 X22.715Y44.88
G1 X23.518Y45.097
G1 X24.338Y45.277
G1 X25.171Y45.418
G1 X26.018Y45.521
G1 X26.878Y45.583
G1 X27.749Y45.604
G1 X28.621Y45.583
G1 X29.48Y45.521
G1 X30.328Y45.418
G1 X31.161Y45.277
G1 X31.98Y45.097
G1 X32.784Y44.88
G1 X33.57Y44.627
G1 X34.339Y44.339
G1 X35.089Y44.017
G1 X35.819Y43.661
G1 X36.528Y43.274
G1 X37.215Y42.855
G1 X37.879Y42.406
G1 X38.518Y41.928
G1 X39.132Y41.422
G1 X39.72Y40.889
G1 X40.281Y40.33
G1 X40.813Y39.746
G1 X41.316Y39.138
G1 X41.788Y38.507
G1 X42.228Y37.854
G1 X42.636Y37.18
G1 X43.009Y36.486
G1 X43.348Y35.773
G1 X43.652Y35.042
G1 X43.918Y34.294
G1 X44.146Y33.53
G1 X44.335Y32.751
G1 X44.484Y31.958
G1 X44.591Y31.153
G1 X44.657Y30.335
G1 X44.679Y29.507
G1 X44.657Y28.679
G1 X44.591Y27.861
G1 X44.484Y27.056
G1 X44.335Y26.263
G1 X44.146Y25.484
G1 X43.918Y24.72
G1 X43.652Y23.972
G1 X43.348Y23.242
G1 X43.009Y22.528
G1 X42.636Y21.834
G1 X42.228Y21.16
G1 X41.788Y20.507
G1 X41.316Y19.876
G1 X40.813Y19.268
G1 X40.281Y18.684
G1 X39.72Y18.125
G1 X39.132Y17.592
G1 X38.518Y17.086
G1 X37.879Y16.608
G1 X37.215Y16.159
G1 X36.528Y15.741
G1 X35.819Y15.353
G1 X35.089Y14.998
G1 X34.339Y14.675
G1 X33.57Y14.387
G1 X32.784Y14.134
G1 X31.98Y13.917
G1 X31.161Y13.737
G1 X30.328Y13.596
G1 X29.48Y13.493
G1 X28.621Y13.431
G1 X27.749Y13.41
G1 X26.878Y13.431
G1 X26.018Y13.493
G1 X25.171Y13.596
G1 X24.338Y13.737
G1 X23.518Y13.917
G1 X22.715Y14.134
G1 X21.929Y14.387
G1 X21.16Y14.675
G1 X20.41Y14.998
G1 X19.68Y15.353
G1 X18.971Y15.741
G1 S0
; return to user-defined finish pos
G0 X0 Y0

This is the g code for a hexagon that works fine. It is similar just with less lines and much longer segments.

; LightBurn 1.4.01
; GRBL device profile, absolute coords
; Bounds: X11.38 Y62.63 to X55.22 Y98.52
G00 G17 G40 G21 G54
; Cut @ 1000.002 mm/min, 50% power
G0 X22.338Y62.627
; Layer C02
G1 X11.375Y80.573S500F1000
G1 X22.338Y98.519
G1 X44.263
G1 X55.225Y80.573
G1 X44.263Y62.627
G1 X22.338
G1 S0
; return to user-defined finish pos
G0 X0 Y0

This is another file that was imported into lightburn
This file is all curves that generates the work “Pitts”

Clock Pitts.txt (93.5 KB)

I am posting it as a txt file due to the number of lines of code

Per the V1 description of the Jackpot controller:

The board runs FluidNC which is fully GRBL compatible with extended features and easier configuration

An old thread suggests you must turn on Enable DTR for a similar board.

I suspect the curve aspect of this is a red herring. LightBurn doesn’t generate arcs. So both curves and lines are straight segments, only varying in size.

I don’t see anything significantly different in the gcode content itself so I suspect this is a communication issue.

Try applying the “Enable DTR” fix that @ednisley listed. However, I would expect that to be an always connecting or not connecting type of an issue.

A few other things to look at:

  1. Check baud rate in Edit->Device Settings. What is this set to? Try going back and forth between 921600 and 115200
  2. Can you confirm that you have defined a laser spindle and have it active?

That’s what I’d expect, too, but the thread suggested initial communications work (just barely) well enough to get started, then it chops out chunks of G-Code as things get underway. That would explain the “invalid g-code” part of the error, at least.

Yeah. This is why I’m thinking communication error. The “working” vs “non-working” g-code is not significantly different in terms of content. So implies an issue with volume or something else.

Let’s see what OP comes back with…

DTR was tried on and off with no change
I will try switching the baud rate
As far as a laser, I will be using a NEJE A40640 that I was using with my previous Rambo controller.
I do not have the laser connected as I was just trying to get the X, Y and Z working correctly prior to firing up the laser.
After I try switching the baud rates I will connect up the laser and try it then

I was actually referring to within the controller. Has a laser been defined and set as active? If not, it’s possible that the controller is not in Laser mode.

I did not get to try hoking up the laser yet
My question is why would the laser matter if the object with only straight lines outputs correctly and the objects with curves do not ?

Maybe I am missing something here

By the way, I appreciate all of the help you have been providing, your help is priceless !


The definition of the laser in the controller is an independent activity to electrically connecting the laser to the controller. I’m referring to the former.

It wouldn’t necessarily. I’m theorizing that this has nothing to do with straight vs curved from a processing perspective which I still suspect is a communication issue. However, I’m leaving it open that there may be multiple things at play with different parts of the erroring from communication and another from a configuration issue.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.