Ligthburn crash when selecting the usb camera WIN 7

After reading all related and closed post in Lighburn, can’t still solve this problem.
I bought a generic USB camera, before paying for it, I test it on my laptop and it worked perfectly with Ligthburn. When I got home, I use Ligthburn camera window to find the perfect place for the camera and proceed to mount it in the laser. After mounting it, on the next day, I was ready to go with the camera calibration, only to find out that every time I choose it, the program “crash” and turn itself off.

I when on and read every publication available in this forum about the camera not working and apply it, I even updated Windows 7 for the mayor part of the day until all updates where installed (I never touch my pc Windows if it is working without issues) . Once again connect the Laptop to the camera and try to select the camera, and every time the result is the same the program is terminated when I choose the camera.

I will try to enumerate all the things I have try :

  1. Updated Windows 7
  2. Change the recommended selection on the configuration and any recommendation on this forum.
  3. Disable the laptop camera, this laptop camera I can select with no issues and it shows in Ligthburn.
  4. I’m running Ligthburn as an administrator.
  5. Try the USB in all the different ports of the laptop.
  6. Try the webcam with a online camera test, and it is working with no issues.

Here are some useful pictures that might be of help to determining my problem

  1. The error

  2. OS

  3. Drivers information:



4: Pictures from USB camera taken with a online test webcam site


  1. Camera spec from the box, not sure they are the real ones

Thanks in advance for any help.
Leonardo Roger

Can you try installing this driver?

Thanks for the fast reply, this one didn’t came on my searches.
The first option didn’t work, run both executables, reboot, and same problem. I did it twice , because don’t know how to check if it made the changes.other than a change in the
Try tu move to the second option and got this message ’ We’re sorry, this download is no longer available.’ try to navegante to MFP but tu much literature and way too confuncing.
Thinking of installin win 10, if my machine can sopurt it. But have to ask if reinstalling Ligtburn first is a good idea, since it worked the first time I plug in the USB camera.

You can try it - it won’t hurt anything. LightBurn stores all your prefs somewhere else so they’ll survive an uninstall / reinstall.

Cameras can be fussy - they need support libraries, and it’s possible that something else installed an updated (or older) replacement for some library used by your camera that makes LightBurn behave the way it does.

Try to reinstall Lightburn, the C++ part failed.
Here is the log file
image
Processing: dd_vcredist_x86_20210914041710.log…
dd_vcredist_x86_20210914041710_log.txt (5.1 KB)

Then the Lightburn installation also failed
image

I can open lightburn, but the error with the camera still persists.

Thanks

Hi again, since my laptop is Windows 7 64 , I download the 64 bits version, there was no C++ installation I can see, but it installed ok.
I went and try to access the USB camera and got this message

maybe this will bring a clue into my problem.

Thanks again for your help.

Hi, any thoughts on my last two messages? ,
I’m thinking to habilate and old laptop, format the disk, and have a clean installation of windows and dedicate that machine to lightburn only. I’m just waiting on your thoughts on the last 2 messages I send before commiting to format the disk. I have a person install all the latest drivers with a special tool, and didn’t get it to work, the only thing is that I will have to add a external keyboard to the old laptop, since I discard that laptop because I dropped a coffee over it.

Please advise
Thanks in advance

:thinking: Just a thought …

but since Windows 7 has not been supported for some time now - and you are considering formatting the drive, and dedicating this laptop to your laser …

Have you considered installing a Linux system?

It’s lighter on hardware requirements … and I believe LightBurn supports it, plus your camera should work just fine.

Ask your friend with the ‘special tool’ what his / her thoughts are, then proceed from there.

Thanks for your reply, I had grow from the first window in college, up to XP and 7 , turning to Linux at this point will be hard for me, but thanks for your advice.
I can install up to windows 10 with my eyes close. Mi problem , I think is that my actual laptop have got lots of installation, even SAP software that I use to use at office , and never took it out, lots of installation of 3d software and other stuff, so whipping of the hard drive had been in my mind for a long time now.
And since I had the windows 10 licence, with no use laying around in some old email, I will give it a try.,
Thanks for your help

I also grew up with the Mircosoft operating system … before ‘Windows’, the first ‘GUI’ I worked with was ‘Multi-View’… but let’s remember that in October 2009 Windows 7 was the first NT based Windows that was released to the public.

At that time, Linux was still in the arena of, and for ‘enthusiasts’… and defiantly not mainstream.

I would strongly urge you get a distribution of Linux that can be temporarily tested from a USB stick, so it does not interrupt your current operating system … and see how it looks.

I think you will be amazed how simple it’s become.

If you are dedicating a machine to your laser… and LightBurn runs on it …

Why NOT take the plunge, wipe the drive, install a version of Linux you like the looks of, put LightBurn on it … and off you go.

A robust operating system and a great way to control your laser!

#justsayin :sunglasses:

… it’s all up to you.

Hi, the usb options before committing to Linux sounds great, any link that can help me get the Linux up and running in no time?
Thanks in advance.