Lines shifts during a burn

Im having an issue that is becoming more repeatedable the design on lightburn shows the layout properly but when i start engraving the line layer shifts to the left and overlaps another text layer i have attached the lbn file along with the picture of the issues it happened before on another file that i was trying to engrave.

Here is the link for the ligthburn file because its larger than 4 mb.

If anyone has any insight that would be greatly appreciated

If its only happening on fill passes I’d try to drop the speed a bit and see if it repeats. If it does, or the speeds you’re running are speeds you’ve previously been running without issue I’d do a once over of the hardware for the X axis. One of the first things I would check is that your set screws on the motor pulley havent come loose.

Run this test pattern on cardboard at a high speed:

BacklashTest.lbrn2 (197.6 KB)

If it doesn’t come out perfectly, then you have a simple test pattern for your loose-screw hunt inside the machine.

How big, is your work area?

I guess I’m not follow how this is supposed to look… the preview on mine is totally different than what you pictured

I see the pattern has shifted up… I assume that’s the scan direction, bottom up.

Can you run the green layer by itself, doesn’t have to be on your material, anything cheap. I know it the file I have has the other two turned off.

Although not likely a cause of this, you should check the start speed in the controller. Most of these are 20mm/s. You have a layer with 16mm/s, so it might be only giving you minimum power.


I did the backlash test, the lines most of them were fine, the test was conducted at 300mm/s but if you can notice the letters f & b had bumps along the lines, the distances on the right side of the drawing match.

we ran the job again, but with having spaces between the pieces inside of having the frame lines overlap and it works flawlessly, we have a suspicion that when we have the frames of the pieces overlap and set remove overlapping lines in the optimization settings on it causes this issue, but when we set them apart it works, but I’m not sure how this can relate to that.

In regards to how I ran the job, we set the fill red layer running first as I turn off air assist, then run the green engrave line and cut lines after with air assist on. the work area I’m working with is 20x28.

All of these in red are from a mechanical anomaly. Something is loose…

It’s occurring when the axes change direction. This direction change causes a ringing in the mechanics.


Something is loose in the Y axes direction…

Good luck


When I ran it at slower speeds 30mm/s the ringing disappears, but I will do a check on the screws to confirm, as well thank you,

but I don’t think this is what causing the main issues of the topic tho.


However, if it isn’t working right, then there is a problem… Clean them up as you go.


The wobbles suggest there’s something loose in the laser head shaking as the direction changes. It eventually settles down at (mostly) the same place for the test pattern, but it may not behave that way on your layout.

However, that cannot account for both problems in your photo:

The text is misaligned horizontally with respect to the vectors and we can eventually figure out which layer is actually offset.

However, the vector to the right of the JB box is broken. The LightBurn file shows that vector as a single stroke, so it should be drawn in one continuous motion. Looking at the photo suggests the laser was off when either the head or the material moved a millimeter or two along the Y axis, which seems impossible while the job was running.

Did you pause the job in the middle of that vector when you saw the misalignment around the JB label, bump the material, then cancel the job? I can imagine the controller would finish the vector after restarting, before cancelling the rest.

If that’s not what happened, what did?

Hi Ed,

I have checked the laser head and tighten it, so hopefully that will resolve the issues of the ringing.

To answer your questions, the whole vector part of this drawing was on a separate layer, and that layer started after the text(fill) Layer, I send the fill layer separately as I need the air assist to be off as it usually provides better results, then I turn it back on and start the cutting layer (line), I was keeping an eye on it and the moment it happened it stopped it, but that whole upper line and boxes of the far top right are part of the same layer that was running continuously, ’

If you take a look at the pictures below, the issue replicated on another job we did previously, with the horizonal misalignment between the text and vectors. That’s why I believe its more of a software glitch as we have the theory above and not sure if it even makes sense.


Everybody wants their laser to have a software problem, but misalignments rarely turn out that way. I’m willing to be convinced, but you’re gonna hafta prove it. :grin:

It is possible that the engraving is misplaced and the line layer is exactly where it should be; the lines look offset because they happen after the text goes down, so they’re obviously wrong.

Load up one of your jobs, reduce the power settings to mark some cardboard, and let’s find out.

Before running the job:

  • Use the Click to Move tool to position the laser at easily located points in the layout by snapping the cursor to corners / text points / whatever
  • Manually pulse the laser to mark those points
  • Maybe add Sharpie crosshairs to make them more obvious, but don’t move the cardboard

You now have marks on the cardboard corresponding to all those points in the layout.

Run just the engraving layer, then repeat the Click to Move process to verify that the same points in the layout correspond to the original holes on the platform. If they do not, then the machine has shifted while engraving, so that the controller’s coordinates no longer correspond to the same physical positions. If it shifts, then I’d expect the layout points to match the newly engraved positions, not the original holes.

If they’re OK, run just the vector layer and repeat the Click to Move process. Moving to the same points in the layout should continue to drop the laser beam into the original holes in the cardboard. If they don’t, then the machinery shifted while doing the vectors, with the same observation about original vs. shifted positions.

Now, if the final result is that the engraving is misaligned with respect to the vectors, while the Click to Move points still line up with their original holes, we can think about software problems. :grin:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.


After another month of debugging and testing, the problem is solved:

We figured it out, I kept looking around and it was actually PWM Raising Edge. [We] ran a few jobs where the machine had an issue doing a fill then doing lines because it ran out of sync, and it did it flawlessly.

The relevant doc:

The design didn’t show any skew, because each individual element was so small we couldn’t see their slanted edges, but engraving the overall layout across the entire platform gave the incorrect edge setting plenty of opportunity to wreck the positioning.

Bottom line: When your Ruida-based machine has a position mismatch between vector lines and raster engraving, try flipping the X axis “PWM Raising Edge Valid” switch.

AFAICT, the correct setting will be False (switch OFF), so if the switch is ON that’s a clue.

Also, the default configuration has been wrong in many machines, so do not assume the switch setting is correct just because you never changed it.

1 Like