Linux cannot connect to laser unless root

Hi all,

I’ve scoured the forum posts for help on this topic and have unfortunately been unable to resolve this issue.

I’m failing to get Lightburn to connect to my laser engraver as the normal user (non-root) as it says “Port failed to open - already in use?”. I have no problems if I run Lightburn as root but this is a lame workaround. I have made the changes to the udev rules and the permissions of /dev/ttyUSB0 are 0666 which is read/write to all users.

I’m able to communicate with the laser engraver (by issuing GBRL serial commands) via Minicom as the normal (non-root user) which points the fault at LightBurn, and not my linux/serial setup.

It’s such a shame as LightBurn looks good but I cannot use it as it stands.

I’ve tested version 1.4 and also an earlier 1.3.01 version to see if that made a difference. I’m running Ubuntu 22.04.3 LTS.

Any help would be very welcome !


Did you complete all the steps for installation in the instructions?

Installation & Setup - LightBurn Software Documentation

Specifically, did you set your group permissions?

sudo adduser $USER dialout && sudo adduser $USER tty
1 Like

Thanks for your help. I’d missed adding the user to the TTY group which has now fixed it. Thanks

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.