Linux Lightburn

I run the latest version of linux debian bullseye and keep up with updates to the system. Since version 1.2.02 I am unable to update LB due to a requirement for GLIBC2.29 which is not ported to debian as of yet. Maybe a docker might be a better solution for distributing LB for linux.

That does surprise me since most Linux distros are based on Debian. It’s a gnu licenses module…

Distributor ID: Ubuntu
Description: Ubuntu 20.04.5 LTS
Release: 20.04
Codename: focal
LightBurn 1.2.04 Thu 2022-10-13 @ 14:13

Did you try and install that lib for other distros like Ubuntu?

Here is how to install it in Ubuntu… although I never had to do this…

A definitive answer would probably have to come from someone who would be more aware of something like this such as @JohnJohn

When I had Debian, I used a lot of Ubuntu modules with no issues… Especially for wifi on proprietary devices.

One of the reasons I moved to Ubuntu, Debian is ‘pure’ so I ran into a number of issues with such a stickler on ‘open source’…

Good luck


1 Like

I appreciate the vote of confidence but I haven’t danced with Linux much at all.

I’ll see if one of our Linux enthusiasts can reproduce this.

What version of GLIBC are you running and what version of Debian is it?

1 Like

debian buster with glibc 2.28.

compiling glibc is a no go. tried it and broke my system quite badly for a couple of days. So installing a version of glibc from another distro is not going to happen either.

I understand completely…


what’s telling you that the problem is the GLIBC version?

I’m running GLIBC version 2.31 and LightBurn runs fine:

me@My-MacBookAir:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 20.04.5 LTS
Release:        20.04
Codename:       focal
me@My-MacBookAir:~$ ldd --version
ldd (Ubuntu GLIBC 2.31-0ubuntu9.9) 2.31
Copyright (C) 2020 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
Written by Roland McGrath and Ulrich Drepper.

I guess that 2.3.1 is slightly older than 2.29 then. What’s telling me is when I run lightburn from the command prompt it fails saying it requires 2.29 glibc. which would be a minimum version not an absolute or max.

I mistyped and added an extra period… the command output quoted shows it’s 2.31 and it really is Linux( Kubuntu 20.04 ) and not MacOS even though I’m running on Apple hardware.

I had attempted to compile and use glibc 2.29 in a separate directory on my system. This failed when I ran ldconfig and caused a very unstable computer. i finally recovered the system by using a live CD version and chroot’g into the HD where the issue was to remove a couple of things as well as re-running ldconfig.

Today, I took a differant approach and used LD_PRELOAD=/opt/glibc/lib/ ./Lightburn from the install directory and it worked. Lightburn 1.2.04 starts and runs with the one simple change. I’ll add it to the desktop using a command line that preloads libm and I should be able to run newer versions. I hope this information will help someone in the future who has an older system and needs to run a program using new libraries.

1 Like

Mark this as a solution, so others can find it…



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.