LinuxMint does not find my laser

I have tried the laser again on Windows and it works fine but in Linux it doesn’t see it. I have the newest lightburn file I installed and still nothing. I tried to import the laser file from the Creality lightburn file but it still would not work. Is there a linux guru out there that could throw me a bone? I hate to have to install windows just for the laser :frowning:

Oh and I did forget about linux being case sensitive and fought for over an hour to install the RUN file because I forgot to capitalize the B in lightburn sigh. So now you know my one brain cell does get tired and shuts down a LOT.

Forgot - also the screen can not be resized to fit on my tv I am using for a monitor. I have tried 16:9 and 4:3 modes and I can resize left and right but not up and down so I cant see the bottom of the screen.

Did you follow the instructions for installing Linux in the documentation?
Installation & Setup - LightBurn Software Documentation

Particularly the portion of running this command?

sudo adduser $USER dialout && sudo adduser $USER tty

I thought i did as that allows everyone to access the usb which I can with my flash drives, external hard drives, etc. I will do it again and see what happens. Lightburn is installed and runs great but even when I see the tty port it never connects to the laser (Creality Falcon 10W). Will try that again tonight or tomorrow and report back!!

Note that you may need to relogin for the new group permissions to be reflected in your session. Or simply reboot.

I got it to work!

I tried the sudo again but to no avail so I redid linux and only used 1 account this time and then it worked. Would think with sudo it would apply to all accounts on that linux but maybe not…?? Only thing I can think of that happened is I was on a different login than what I installed on. I have been braindead so hopefully this fixes that too :slight_smile: Thank you for the help!

1 Like

No. The way that it works is that the currently logged in user will be added to dialout and tty groups. $USER is an environment variable that when referenced will resolve to the current user.

I didn’t realize you had been trying to do this across users. You most likely should have been able to run the command with the same user that you’re running LightBurn and had it work. Or else you could have substituted $USER with the name of the user you wanted to use to run LightBurn.

In any case, glad you got it to work.

Sorry, I did not explain very well :frowning: Forgot about the variable $USER not being ALL USERS but just the current one. I never even tried on my account I was running lightburn from DUH!!
Again, thank you for the help you got me going in the right direction to fix it and I really do appreciate it.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.