Little dot with the new update

Since the last update when I burn an image the laser returns to start point and then burns a dot. Is this fixable please?

Thanks

Adri

Can you make something simple (like just a small square) and then save the gcode file and upload here?
I see you have an EleksMaker machine… the controllers they use are bare bones and I’ve seen some diode machines fire the laser in random situations because the circuitry lacks basic safety features.
How long does the laser fire for when returning to the start point?
Having a gcode file will just help rule out anything silly going on - I can confirm if it’s actually getting a command to fire (99.9999% sure it’s not, but who knows).

OK. Here it is. This didn’t happen with the last version of LW though so I may have to go back to a previous version.

Thx for helping.

test.lbrn (3.3 KB)

That’s a LightBurn project file, not generated gcode. Click the Save GCode button near the ‘Start’ button and post the output of that. The project file won’t contain all your device settings and prefs, so the saved gcode is better for debugging.

I have noticed the same behavior on my marlin machine. It did not used to happen with lightburn < 0.9.07, but now it does, and I cannot figure out why, There is nothing different being generated in the gcode that I can see, and it doesn’t seem to do it with every file. I will try to get more details the next time I notice it happening, but for now I just wanted to post to add that Nicholas isn’t alone.

edit: one thing that I just remembered - I have return to zero disabled, so the dot happens after a slight pause (half a second or so) at the end of the toolpath.

Is it generating a simple dot? Can you show your cut settings? You may have the cut-through mode enabled with an end pause.

Hi. There isn’t a ‘Save GCode’ button. Do you need to run the project first before you can save to GCode?

TIA

Adri

Thx for that but that button isn’t there.

I’m on a 32 bit version of the software. Does that make a difference? Also, Can you provide me with a rolled back version 0.9.07 in 32 bit please so I can test?

Thx for the help.

OK. Was in beginner mode. Here’s the GCode test file contents as I can’t upload a .gc file

; LightBurn 0.9.09
; GRBL-M3 (1.1e or earlier) device profile, current position
G00 G17 G40 G21 G54
G91
; Cut @ 6000 mm/min, 100% power
M9
M5
G0X0Y0
M3
G1X38S255F6000
G1Y-5.18
G1X-38
G1Y5.18
M5
M9
G1S0
; return to starting pos
G0 X0Y0
M2

Ah, sorry about that. Please go to Edit > Settings, then in the very top left corner of the settings dialog is a “Beginner Mode (Simpler Interface)” checkbox. Please uncheck that and then click OK, bottom right. You should now see the “Save GCode” button.

Done. See above. Thx.

Any chance I can have a copy of 0.9.07 32 bit to try. Can’t see a download for it anywhere.

You can download 0.9.07 from here: https://drive.google.com/drive/folders/1j8Z0gfKS0ert7n0qnN05W5aimU6Fontm
Please save the project for the gcode you generated above, load it into 0.9.07 and then save the gcode there. And of course let us know if it still happens.
I’m not seeing anything in that gcode that would cause that.

OK. So 0.9.07 does not have the problem that 0.9.09 has in 32 bit version on my setup. I just tried 2 jobs and a test file and none had the burnt dot at the end.

I’ll stick with 0.9.07 for the time being until the problem is solved.

Thx for the help.

Ok, but we don’t actually know what the problem is as there’s nothing in the gcode that would indicate why that’s happening for you. Could you please still provide a gcode file generated from 0.9.07 as I requested before @adri123 ? It would be extremely helpful.

; LightBurn 0.9.07
; GRBL-M3 (1.1e or earlier) device profile, current position
G00 G17 G40 G21 G54
G91
; Cut @ 6000 mm/min, 100% power
M9
M5
G0X0Y0
M3
G1X38S255F6000
G1Y-5.18
G1X-38
G1Y5.18
M5
M9
G1S0
; return to starting pos
G0 X0Y0
M2

The gcode from the two files you’ve posted is line-for-line identical, so this is very strange. Can you post a screen shot of your device settings on 0.9.07 and again on 0.9.09? I can’t think of anything that changed in the way the comms are handled between the two, but there might be, and that’s the only thing I can think of that could explain a difference in the output.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.