Lost connection to xtool when trying to install rotary

I am running the latest version of everything. all I did was try to set up the rotary. been using in for a couple of weeks with no issue. free trial about to end. will NOT buy it if I can’t get it to work correctly. I tried uninstalling and reinstalling but it keeps all my old settings. I don;t know what happened. same question asked on another forum and no solution, just the same suggestions over and over. cable is good. laser works with the basic software that came with it. I spent the last three weeks learning the software and apparently it was all for nothing. What am I missing. Ive done the add device over and over and over…etc. all I did was click enable rotary and plug it into the laser. nothing every since. I have since disconnected the rotary and still no resolution

I don’t think you’ve stated the symptom. What exactly are you experiencing? And is there any information on screen that you can share when this occurs?

Also, please take a full screenshot of LightBurn with Laser window showing please.

not understanding not stating the symptom. ive been using lightburn for almost 3 weeks. decided to install the rotary for the d1. it suddenly stopped connecting and I cant do anything because it cant detect it. used multiple cables, etc. the screenshot shows the latest attempt. I downloaded the configuration file per xtools instructions and what is showing is a configuration file, not the laser. I was changing something in the software to make it recognize the rotary and I cant get anything at all to work now. all I can share is it says nothing is found

Where is it saying this?

Can you pulldown the Ports field in Laser window and confirm whether or not you have other ports showing in that field?

Can you provide the following:

  1. Screenshot of Edit->Device Settings
  2. Output of Console window
  3. Screenshot of MacOS System Report->Hardware->USB->usb-serial device
  4. Output of this command in MacOS Terminal:
ls /dev/*usb*

Also, some followup questions:

  1. Can you confirm you’ve rebooted your computer and power cycled your laser? Try in this order, reboot computer, power cycle laser, then start LightBurn. Make sure the correct port is showing in Laser window.
  2. Are you connected directly from laser to computer? Or do you have a hub or something else in between?
  3. Are you able to connect to the laser using LaserBox?
  4. Have you had any OS updates or any other changes to your system between the time it worked and it did not?

in response to follow up questions
1.rebooted and recycled power many times over the last 3.5 days
2. I have a hub as my usb ports are type c and cables are type a. besides, it worked with the exact same hardware prior to trying to install rotary.
3. laserbox does work, yes
4. No system changes that I am aware of
as far as ports showing
output of terminal command was /dev/cu.usbserial-146330 /dev.tty.usbserial-146330
output of console window. waiting for connection…then port failed to open -already in use?

Have position or number of devices changed?

I don’t see anything obvious from what you’ve shared so far. Can you confirm the firmware version that’s installed?

What rotary were you trying to use?

If it’s RA2, did you update the firmware to accommodate the rotary?

There have been a lot of other xTool users that experience connectivity issues even after it was working at one point. I suspect this is possibly related to the D1 not switching to GRBL mode. I thought I saw at one point a way to detect what mode the D1 was working in but not sure what that was. Possibly a light color. Is this information available in any of the included documentation?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.