Low power output when using Lightburn

Hi I have a DIY 8000 12v 5500mw laser. When using the rather limited program that came with the machine, it burns images and text great. However when I switch to Lightburn, which enables me to do so much more, the power is so much lower and takes ages to create anything.
E. G. and small image in Engraver Master comes out detailed at a speed of 2000 and takes six minutes. The same image in Lightburn takes over two hours and I have to lower the speed to 100 for it to even mark the material. I think it may be something to do with the GRBL settings, which the machine located are GRBL 1.1.e or earlier. The machine manufacture recomends 0.5.2 ? Could this be causing the drop in power between the programs? S value is 255? Can I change the S Value? The program is great fro producing designs but it is fustrating that everything takes so long to complete?

In LightBurn, what is the S-value max set to in Edit > Device Settings?

Then check your firmware settings by typing $$ in the console, and look for $30. If you have that value, it will tell you the maximum S value the firmware is looking for, and it should match the setting in LightBurn.

What speed setting are you using in LightBurn? You said “100”, but 100 what? mm/sec is a lot different than mm/min, so it’s worth checking what your speed units are - the default is mm/sec.

Thank you for your response. I am running mm/min and the s - value is $255. I have been reluctant to change settings as the last laser I had overheated, and I was scared I might ruin this one. My son was not very happy as he had bought it for me.
So in basic settings I should change 255 to 1000? mm/min to mm/sec?

mm/min is more appropriate for a diode, so leave that - if you were using 100mm/sec, that could explain why you weren’t getting a burn, which is why I asked.

For the S max setting, the important thing is that they match - the number itself is mostly irrelevant, but LightBurn and your controller both need to agree on what the largest number used will be.

If you and I are listing to the radio and I tell you to “set the volume to 10”, the 10 is just a number. If you think the volume is a percentage, but I think it’s a scale of 1 to 10, then you and I have very different ideas about what “volume 10” means - I think it means as loud as possible, and you think it means 1/10th of the possible volume.

LightBurn and GRBL are doing the same thing - If GRBL has been told “1000” means full power, but LightBurn is told it’s 255, then LightBurn is going to be sending 255 to the controller when it wants full power, but the controller will give you roughly 1/4 power, because it thinks 1000 is the largest value, not 255. Does that make sense?

1 Like

Thats a really good explanation, so really I have to find what the value of the controller is set at? and then match the number in Lightburn.
I suppose I am being a bit picky really at the laser is working fine, just taking a long time! Basically taking four times as long as the original program, which would suggest the setting needs to be $1000. However my son has threatened me not to touch anything as he won’t fix it again! because if I do put too much power through the controller I could overheat it? I think !
Thank you for your explanation, it has helped me understand how the controller and the software communicate. It is appreciated.

Depending on the diode, it’s feasible that you could overheat it, yes, but if that’s the case then it’s not very good hardware - You shouldn’t have been sold something if normal use can destroy it. If you’re worried, set the S-value setting in LightBurn higher and use 80% instead of 100%.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.