Low power using lightburn.....did not change a thing in device settings

I have been using my laser about 2 years. Lately i am having power problems. I first thought it was my laser module to be defect or dying. A member on a laser related forum suggested that i tried to find if the problem also was present using LaserGrbl by doing a lasertest. And doing just that the laser was doing a far better job. I checked the device settings in Lightburn… S-value max at 1000. But for some reason the laser lacks power doing a project using Lightburn software.
Any suggestions on where to look…by my knowledge i did not change any device settings.

Check your speed settings.
image

If above is not problem, you can enter $$ into console and paste your settings here.

Thanks for your input. Speed settings are set at mm/min…thats not the problem. I have not changed a thing since i started using the Lightburn software. I only updated.

Updating can change your settings. Try going to file > preference > load pref. backup and pick one before your update.

4 Likes

Thanks for your suggestion. I cannot update to the latest Lightburn version unless i pay …after 1 year of use there’s no longer the option to update. I can only remove the current version i have and install that same version again.That would probably solve nothing.

What was it you updated?

LaserGRBL may be using the M3/Constant Power mode command by default, which means your laser is always outputting at the maximum power you set for a project, regardless of speed. LightBurn uses M4/Variable Power modeby default, which causes power to scale according to speed – starting at 0 when the laser is stopped, and ramping up to the max power you’ve set as it accelerates to the speed you’ve set.

You can enable Constant Power Mode in the Cut Settings Editor, and see if the behavior changes.

If it does, you may need to slow your job down if you want to return to using Variable Power mode (which often yields better results). If you set a project speed in excess of the maximum speed your laser can travel at, it will never reach full power either, when using Variable Power.

Thanks for the reply. I have been trying many different things…“constant power mode” in the layer tab is one of them. I now have it on as standard. Does not make a difference. For example what the problem is. Using LaserGRBL i can cut through 2mm thick leather in 2 passes at speed 500 and 100%power…for the Lightburn software i need 3 passes at 300 speed 100%power for the exact same 2mm leather…it used to be faster than that in Lightburn when i look at the material test i did about 1 year ago.

I updated to every version that Lightburn suggested/promped me to get…the updates only come for 1 year after you buy a license for the software…if you want the absolute latest update and newer options you have to pay again. The software worked fine until a few months back…having changed nothing at all it does no longer work as good.

If you can save and share the GCode produced by LaserGRBL versus LightBurn we can compare your settings to identify any differences. In LaserGRBL you just go to FileSave (I believe) and in LightBurn go to FileSave GCode, or click Save GCode in the Laser window.

There are only a few variables could possibly cause a difference in power output between LaserGRBL and LightBurn. Those are Variable/Constant Power mode, Speed, and S-value Max.

I will get to that tomorrow. So lets say i cut a simple square or circle using lightburn and lasergrbl…with the same power and speed…and save both files as gcode and show it via printscreen would that be sufficient??

Yes. It will be best if you upload the files themselves here so we can take a close look, but screenshots will suffice provided they show all the GCode (particularly the information at the start).

1 Like

Here are both files…its an image because LaserGrbl does not support the DXF files i normally use. square with holes Laser GRBL.nc (24,7 KB)
square with holes Lightburn.gc (21,5 KB)

Both have the same settings 1 pass at 100% and 250mm/min. The image is the same size.
Laser GRBL cuts trough completely…Lightburn barely halfway to the 2mm thick leather.

You are using Constant Power (M3) mode with LaserGRBL, but Variable Power (M4) mode with LightBurn.

What happens if you enable Constant Power mode in LightBurn?

In LightBurn, please also enter “$$” in the Console window, and copy and paste the response it returns.

Hi

You are correct , i forgot to turn on constant power mode. Did the test over with constant power on…no difference. When i type $$ in the console i get this.

Using an image is complicating the comparison – I am not sure how LaserGRBL handles images but it is actually emitting lower S values than LightBurn is (albeit using Constant Power). In any case, with LightBurn, images are not intended to be used for cutting.

Please create a small rectangle in LightBurn and go to File → Export and save it in SVG format. LaserGRBL will be able to load that. Set that rectangle to the exact same settings in LaserGRBL as LightBurn and share the GCode.

Just as an aside, I know this should affect both software, but make sure your lens is clean. It slowly creeps up on you.

1 Like

When’s the last time you’ve cleaned the laser lens. That solved my issue in the past.

Hi , thanks for you suggestion/advice. I allready replaced the protective lens. I also cleaned the laser lens behind that. The cleaning of the laser lens and replacement of the protection lens simply cannot make a difference software wise. LaserGRBL does cut the project faster/easyer at the exact same settings than the Lightburn software does. If it was only lens/cleaning/replacement related there would not be any difference.