M1 Pro mac USB conection

Hello, i am new to the forum but i’ve been suing Lightburn on different machine for a couple of years now.
These days i got an M1 Pro macbook pro, and when i try to connect my 3018 to the mac via usb, and get it recognized from Lightburn, the software wont find any usb, either with and adapter or a dongle.
I got the laser blinking as soon as i click “look for laser machine” but then there’s nothing on the list.

Any idea? It was working with a retina macbook pro til last week.


Check to see if you can see the device in Terminal:

ls -l /dev/*usb*

If you can, then it’s likely you may need to setup the device manually. Either go through the manual creation process or export the device from your other computer and import into the new computer.

If you cannot see a device then it’s likely a driver issue. Confirm device type in System Reports->Hardware->USB. I’ll assume it’s a CH34x. Download the appropriate driver and install then cycle back from the top of this post.

There’s often a thousand different reasons why macs and third party devices like ours don’t communicate well. But the one’s that worked for me recently and often aren’t mentioned, are the cables/dongles. I had genuine apple USBA-C dongles that didn’t work. However, I tried an old genuine apple USB-C Digital AV Multiport Adapter and it works perfectly every time. I’v e also heard rumour of USB 2.0 accessories being more successful? Try every combination / permutation of USB 2.0, 3.0, 3.1, cable, dongle, powered /non powered hub type dongle, expensive apple certified, cheapo knock off brand…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.