Mac Pro 5,1 X5680 64Gb RAM, 500GB NVME Big Sur latest lightburn - Lightburn 97% CPU

As above. Ive reinstalled Lightburn, created a new file exported and and reimported and cleaned up the dxf.

When I start zooming in the cpu hits 97%. I thought this program was designed be very CPU friendly. It’s almost unusable.

I’ve rebooted into windows 10 with the same file ( not virtual ) and it works fine.

can anyone help?!

combs test.lbrn (2.9 MB)


I have tried to download your file but it takes oceans of time even though it is only 2.9 MB. I think there is something wrong with this file.

… apart from the fact that it took a long time to download the file, which is probably related to the maintenance of the LB server today, I have no processor overload by zooming into the details.
(Macbook pro 2/2014, Big Sur 11.2, LightBurn 0.9.20)

Works fine for me on Linux. I can scroll in and out and zoom all around and it responds fine with very little CPU usage.

What is the resolution of your display, and which version of LightBurn are you running?

it’s a 4k 28 inch, RX580 4Gb running at 3008 x 1962. The lbrn file uploaded isn’t the issue because I have imported the original DXF directly and then through Corel Draw by importing the dxf to Corel Draw and then exporting it.

That’s not terrible - My Windows machine runs two monitors at 2560x1440, and even with your file loaded and stretched across both displays, I max out around 13% usage in LightBurn.

It’s possible this is an interaction with Big Sur and the framework we use. There was an issue a few years back with MacOS doing gamma correction on the image being rendered to and presented to the OS. I’ll have to get Big Sur running on a machine to see if I can reproduce this.

0.9.20 :slight_smile: I had the issue again yesterday importing another DXF into Lightburn. He’d set the scale massive, so I reduced it from 100% to 3.9% but then zooming in and out just maxed it out and then it remained maxed out.

If the DXF was imported at massive scale, then reduced, you might have a LOT of nodes in the design, and that could be part of it.

DXF files that contain splines store them in a format that isn’t compatible with how LightBurn (or other artistic software) represents them, so they’re converted to line segments within a distance tolerance of the original shape. If you import the design at 100x the actual intended scale and then scale it down, that “distance from the true shape” part of the code is being run at the enlarged scale, so you’d have about 100x more nodes that you should.

In the settings, you can set the DXF import units in the ‘File’ tab, and that will do the scaling before that spline evaluation happens.

You can also use Edit > Optimize Selected Shapes and convert the splines into arcs that are within a specific tolerance of the source:


I tried that and that isn’t going to work. If you look at the file it doesn’t have any curves in it, just straight lines. For the sake of process, I put it through the optimise shapes the difference is 0 because they are all straight lines.

Regarding the import units settings. That makes no difference because of the above. The file has been exported from AutoCAD I expect in the mm units. So, it not that its mis reporting the units.

I opened the same file on my other Mac Pro with Catalina and it zooms in and out fine. So I think there might be some kind of Big Sur thing going on.

Certainly feasible. We’re looking at setting up another MacOS dev system with Big Sur and seeing how much effort would be involved in having a 2nd MacOS build, targeting later versions of the OS. If it’s not a massive hassle to maintain two versions we might do it.

Different DXF today and Lightburn is at 100% so its deffo a Big Sur thing.

I opened your file on an M1 MacBook 13 with 16GB ram. My “average” CPU of all the cores never got above 11%. I am running Big Sur 11.2 and LightBurn 0.9.21, built Wed 2021-02-17 @ 16:12. zoomed in and out.

Which model Mac, RAM and hard drive or SSD are you using?
I offer this as a benchmark for M1 Macs and the Big Sur system plus RAM.

While running, and more importantly, while pegged at 100%, open the Activity Monitor and collect a Spin Dump. (It’s in one of the menus, but I can’t recall which) Select LightBurn, do a Spin Dump, and email that to along with a link to this thread. That might give me some information about what’s stalling.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.