Mac Problems - Device not found

Hello hello.

We have 2 x lasers both with Ruida controllers. Both lasers are found when using LightBurn on our Dell computer but not on our Mac (Big Sur). I’ve been scrolling through the forum posts for a while but have not been able to sort the problem. It seems like he problem may be to do with drivers - I don’t know much about drivers on Macs so if its that then advice and instructions would be great.
I also read that it might just be easier to use an older version of LightBurn - I think maybe 0.9.20 and 0.9.24 - when I download these from GitHub the Mac won’t let me open them.
So, if I can get access to these versions it may be an easy fix.

Thanks!

Are you using usb or Ethernet? I’d assume usb, and my first suggestion if possible use Ethernet.

Using your local network it’s just different packets… no drivers or headaches. If you’re on the local network, you have all that’s needed to communicate.

I don’t run Apple stuff, but I do Linux… See if this thread helps…

Move over to Ethernet if you can… dump the usb :crazy_face:

:smile_cat:

Thanks! I did read that thread but a lot of it went over my head. Yeah maybe I’ll just have a look at the ethernet option. :slight_smile:

Ethernet is really better and will allow wireless laptops to be used.

There is also a Lightburn wireless bridge they sell (when they have them) that makes your machine wirelessly connected to the local lan… No long Ethernet cables…

It is specifically designed for the Ruida controllers UDP communications.

If you have a PI laying around the image is available, so you don’t have to purchase one.


Another option is a cheap wireless bridge, around $20 from Amazon.

Good luck

:smile_cat:

I got it connected. Maybe with an excess of cable but it works! Thanks!

1 Like

Great… How about a quick rundown on how you fixed it. Others will find it useful…

Mark the thread ‘solved’ it that’s the case…

Assume you used Ethernet?

Good luck, have fun

:smile_cat:

1 Like

I have the ethernet cable from the laser connected to the router and another ethernet cable connected from router to Mac. It doesn’t seem to work without the router - Mac cable. If anyone has any suggestions id love to hear them but this works so I’m happy for now.

Is the router on the network?

Most machines depend on the router to give devices IP addresses for use on the local network. This is DHCP or dynamic IP assignment, the converse is a static IP that doesn’t change. The router handles this for you.

The Ruida is pretty dumb when it comes to things other than moving and firing the laser.


When you plug most network devices into the network, they have no IP address and ask the router for an available IP address for the local network.

When I say pc, I mean personal computer, whatever that may be…

It is a static IP set via the console. When you plug your pc into the Ethernet port of your pc, it does what it always does, ask the DHCP server (router) for an address. No DHCP services, no communications.

You can set your pc’s address to a static IP, plug the Ethernet from the pc directly to the laser… if you set it up right it will work… I used to do this quite often.

One of the issues with mixing dynamic and static, is the problem the router will issue the Ruida address to some other device… of course that doesn’t work…

Another option is the Lightburn Bridge, which has a layer of code in it to handle the UDP issue with the Ruida communications.

It’s been out of stock for a while… this is a limited supply…

Good luck

:smile_cat: