Macbook's USB-C port is broken, it doesn't recognize DX tool Pro, can I still use Lightburn?

Good evening.

I have a 1.2 GHz Dual-Core Intel Core m3, Macbook, Retina 2017. This one doesn’t have a USB cable. I can confirm that the USB-C won’t recognize adapters for USB and that it unfortunately can’t connect to the DX tool Pro 20 W. Is there a way to connect without an adapter?

The device has been added correctly and it shows as Ready.
When I click on the Console it gives me the error of not communicating with the USB port.
Something has gotta be wrong with it, since the computer is not new. I was able to use the DX tool software through wifi, because the same thing happened.

Can I still use Lightburn without having to be connected?

I run Mac OS Ventura 13.4

I had some success with a similar controller by using a hyperdrive thunderbolt USB hub.

gotta be wrong? Not usually…

Have you installed the CH340 driver?

This seems like a smooth approach.

Please let us know if this or anything else here is still problematic.

If you download the lbdev file from xTool and Import it into LightBurn, it should set up LightBurn perfectly to work with the device.

Thank you for the suggestions, I mean that something has got be wrong with my USB port. I will try with the driver. My husband has a brand new computer and with his everything works like a charm. I did download the lbdev file from XTool and Imported into LightBurn. The setup, like you say is perfect in both my husband’s computer and my computer. I guess in other words, I am trying to operate the laser without my usb port, ‘wirelessly’. I am able to design and do all the things in my computer. I have been saving the designs in my drive, downloading in my husbands computer and operating from there. It would just be really convenient to be able to operate from my computer, wirelessly. Does that make sense?, Thank you so much,

Help! I am still having issues. I tried installing the driver and got so far as the terminal goes: Then it gives me the error “No such file or directory” when I clearly followed the previous steps.

I bought the amazon cable, didn’t work :frowning:
Am I able to use Lightburn wirelessly any other way?

Thank you for your help.

Because of the unique method xTool uses for wireless communication this is currently unsupported by LightBurn.

I did see some tinkering work done by community members in March and some discussion about it here:

Please upvote it here:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.