Machine and LB stopped working 20% into some cuts in balsa

I set up 16 parts for a model plane to be cut out of 1/8" balsa.
20% into the project everything stopped except the timer to the right of the green bar showing percentage. The laser unit just kept putting out a soft white light.
I am using a Sculpfun S9 that I have only had for 1 month and have done very little with it until I received my air-assist pump, which arrived 4 days ago. Worked great last night
Did I do something wrong in LightBurn or is this a machine issue?
Thank you.

It sounds like a hardware issue with the laser module. You can test by connecting the laser PWM cable to 5V directly. If the laser does not turn on at full power, the diode is broken. Check tha latest of the FAQ here: FAQ - Diode Laser Wiki
Make sure that you wear glasses etc. The laser will potentially fire at 100%.

Yesterday I was afraid it was the laser module so I just put everything back inside ( my setup is just outside a glass door) and sent the message.
Today I drew a small circle to just make a light mark and a small square to cut out.
The laser worked perfectly.
There might be a flaw in my drawing for the airplane parts although the preview showed the cuts in the order I wanted them (inside first) as cutting completely. I would think it should still cut all lines instead of stopping. All lines were on the same layer, only lettering on a different one.
Or could there be something about the Gcode the computer sent to the S9 ?
I don’t think the laser got hot because it is cool outside now. There is a large roof over my setup so there is no chance of rain touching any part of my S9, and the wind blows through nicely.
I hold a Federal General Electronics license so I am protective about how I treat my S9

As also mentioned in the FAQ, the connection to the laser is sometimes unstable. You can exchange the cable for a high-quality one, remove electrical disturbances from the power lines, disable all energy saving functions from Windows. All those things might add up to a more stable connection, but you never know for sure :slight_smile:

Well, I thought I had a good cable. It was brand new and had no kinks or sharp bends. It turns out there must be something wrong with it.
I brought my S9 inside by the door so I could blow the smoke out with a fan and used a different USB cable.
It worked perfectly all the way through the cuts

Thank you very much for the help.