Machine home is front right, could be causing issues?

Hello, i have a lunyee 10w laser and lightburn 1.5.4, My limit switch went to the right front corner so thats how i been using it. I tried to do a print and cut and every single time ive tried, it shows my image as out of bounds! could this be bc of my homing being on the right (negative space)? If i were to relocate my homing switch would it be as simple as that or is there a ton of things i would have to configurate after it is moved? Thanks yall

Are you attempting to use print and cut to cut something larger than your laser bed, or using it to align something printed elsewhere? If you are trying to cut larger than your bed, you need to cut the file into different portions and hide those outside the limits of your bed. This video helped me figure it out when i was having similar isues.

Yes. Something larger. It seems ok if I’m aligning but to cut larger it send the other half of the image way out of bounds after reading the registration marks… I cut the image into 2 separate pieces and burned the first image with the 2 reg. marks then I went to each mark and marked them. But it is always out of bounds in the right top corner…

Absolute Coords requires that you not be in negative space. Having said that, I’d be surprised if your machine was a negative coordinate machine.

Can you provide the following:

  1. To what corner does your machine home?
  2. Full screenshot of LightBurn with your design and Laser window in view
  3. Screenshot of Edit->Device Settings
  4. Run these commands in Console and return the full text output:
$H
$I
$$
$#
?
G0 X10Y10
?
  1. Please describe the motion for the above commands.

Thanks so much… It homes to the top right corner (Limit switch installed), when i put in the commands it homed to the top right switch. Here is the output… Im looking now how to add a screenshot
<Home|MPos:0.000,0.000,0.000|FS:0,0|WCO:0.000,0.000,0.000>

ok

Monport

[VER:1.1f.20230316:]

[OPT:VMZHL,35,254]

Target buffer size found

ok

$0=10

$1=25

$2=0

$3=0

$4=0

$5=0

$6=0

$10=1

$11=0.010

$12=0.002

$13=0

$20=1

$21=0

$22=1

$23=3

$24=25.000

$25=3500.000

$26=250

$27=1.000

$30=10000

$31=0

$32=1

$33=1

$34=1

$35=0

$36=0

$37=1

$38=10

$39=0

$100=80.000

$101=80.000

$102=80.000

$110=20000.000

$111=20000.000

$112=20000.000

$120=500.000

$121=500.000

$122=500.000

$130=1500.000

$131=1500.000

$132=300.000

ok

[G54:0.000,0.000,0.000]

[G55:0.000,0.000,0.000]

[G56:0.000,0.000,0.000]

[G57:0.000,0.000,0.000]

[G58:0.000,0.000,0.000]

[G59:0.000,0.000,0.000]

[G28:0.000,0.000,0.000]

[G30:0.000,0.000,0.000]

[G92:0.000,0.000,0.000]

[TLO:0.000]

[PRB:0.000,0.000,0.000:0]

ok

ok

ok

ok

ALARM:3

Reset while in motion. Grbl cannot guarantee position. Lost steps are likely. Re-homing is highly recommended.

sys.aborts

Grbl 1.1f [‘$’ for help]


This one i marked the registration marks and where it puts it in the preview…part of it out of bounds.

Are you talking about the portion that includes the “This”? If so, that’s on a frame layer so wouldn’t expect that to output.

Can you describe the motion that resulted as part of the commands that were listed? Was there any motion after the laser homed?

Also, did the limit switches come originally with the machine or this is something you added?

Also, please clarify. Your original post indicated that your limit switches were on the front-right but your clarification indicates it’s rear right. Was that a misstatement or is there something more going on.

I’m sorry for the confusion…I sent pics of the project going in from the side instead of front to bottom. But after the commands, it homes to the limit switch and moves off the switches just a couple mm’s so the switches aren’t activated anymore… The 2 switches came factory with the machine. Referring to the registration and out of bounds… it seems to be a bit better than before I know it’s user error on my part, before… No matter how I did it the print and cut would end up completely out of bounds in the upper right corner but now its better but no matter how perfect I think I hit the registration it’s still off sometimes by a couple inches sometimes a few mm’s. I’m hoping that’s me needing more practice. I call it the front right bc the front of my laser faces that corner and the corner my control box is it. Am I wrong? I’m pretty new still and just to have the expert advice that I have my configurations correct on my machine would be fantastic.

Is this your laser?

I’ve circled in green what would be considered the rear-right of the machine. Can you confirm this is where your machine is homing?

Also, can you run these steps please and describe what happens?

  1. Push Home button in Laser window
  2. Enter in Console:
G0 X10Y10
  1. Enter in Console. Then copy/paste the outputted result here in a reply.
?


I wish I had that one :grin:. But this is the one I have and circled is where my homing switch is located.
$H

ok

sys.aborts

Grbl 1.1f [‘$’ for help]

x10y10

x10y10

ok

Sorry, when i type 10x 10y it moves 10mm down and 10mm out from the top homing corner.

In that case this should be considered front-left.

This makes me rethink a number of things.

Can you confirm that your jogging controls work correctly? Up moves up, down moves down, left moves left, and right moves right?

At a minimum, your Origin setting in Edit->Device Settings is almost certainly incorrect. It should be set to the bottom-left dot.

Is this the corner it should be? Where the dot is at now the movements move up for up arrow, down for down, right for right and left for left arrow. If I move it to the corner I screenshot then it is all backwards.

Is this because your machine is oriented rotated 180 degrees from expected? If you orient the machine such that the controller is facing you, do the jogging controls work as expected?

If that’s not the reason, can you confirm whether or not you’ve made any GRBL configuration changes to your machine?

Configurations no, the only thing I changed was the dot position in edit=device settings. I turned the machine 180 and when I hit the arrow buttons the right and left arrows take the machine in correct directions but the up and down are backwards.

Where does that put the orientation of the machine? Does it look like the image you uploaded?

Im not positive what you mean? It seems backwards after turning it.

Can you take a photo of the machine from the perspective that you normally look at it? As-in the front toward you.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.