Machine homes to bottom left corner correct, but reads position as -400, -400,

Everything was working fine. Ortur master pro 2. I assembled the ortur y axis roller. Unplugged the y motor cable and attached to rollor. Decided to move laser to middle of machine. plugged y controller back to motor. when I homed, the laser moves to bottom left corner correctly, but lightburn lists im at coordinates -397, -387. until I messed with settings to turn on rotary device, which i think i set all back to starndard settings, it read home as 0,0. so if i try to 'set position by clicking on to the work area, this is the error i get

error:2

Numeric value format is not valid or missing an expected value.

Starting stream

ALARM:2

G-code motion target exceeds machine travel. Machine position safely retained. Alarm may be unlocked. (Right-click the ‘Devices’ button to reset the connection)

On or near line 2:

Stream completed in 0:00

[MSG:Reset to continue]

ok

Ortur Laser Master 2 Pro S2 Ready!

OLF:OLF 185.

OLH:OLM_ESP_PRO_V1.2.

OLM: GENERAL.

[MSG: Warning: Flame Sensor Disabled by User OverRide]

[MSG: Flame detector active,Ambient infrared value:0]

Grbl 1.1f [‘$’ for help]

[MSG:‘$H’|‘$X’ to unlock]

[MSG:Caution: Unlocked]

ok

i can jog the laser with the manual buttons from the ‘move’ tab but im at a loss




Very likely that you have a work offset inadvertently configured on the machine. This was very common for that model and firmware version.

I suggest you do 2 things:

  1. Reset the GRBL configuration to defaults. This is safe on Ortur machines assuming you haven’t customized your machine in any way.
    Run this command in Console:
$RST=*

This should get you back to a working state.
2. I’d suggest updating the firmware as the later firmware revisions have been updated to avoid this issue.
Ortur – Firmware Repository – Ortur

If this does not remediate the issue can you run these commands in Console and return the output?

$H
$#
?

the $RST=* did fix the issue !!! i’ll update the firmware tonight before going back to the rotary system

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.