Machine is homed but not zeroed

Hi everyone,

I recently extended my Aufero Laser 2 to 431mm x 952MM and added home switches. I have figure out how to tell both lightburn and the controller the new size, and I have gotten the machine to home. However, at the home, the laser shows X-428.00 Y-949.00, and appears off the workspace. The origin is set to lower left, as is the home position.


Screenshot (1)

$#

[G54:0.000,0.000,0.000]
[G55:0.000,0.000,0.000]
[G56:0.000,0.000,0.000]
[G57:0.000,0.000,0.000]
[G58:0.000,0.000,0.000]
[G59:0.000,0.000,0.000]
[G59.1:0.000,0.000,0.000]
[G59.2:0.000,0.000,0.000]
[G59.3:0.000,0.000,0.000]
[G28:0.000,0.000,0.000]
[G30:0.000,0.000,0.000]
[G59.6:0.000,0.000,0.000]
[G92:0.000,0.000,0.000]
[HOME:-428.000,-949.000,0.000:3]
[TLO:0.000]
[PRB:0.000,0.000,0.000:0]
ok

?
<Idle|WPos:-428.000,-949.000,-75.000|Bf:35,7679|FS:0,0|Pn:P|CL:0,100|PS:2,1|VA:24661,0|A:S|H:1>
ok

ok

$0=5.0
$1=100
$2=0
$3=2
$4=7
$5=7
$6=1
$10=2046
$11=0.050
$12=0.002
$13=0
$14=6
$15=0
$16=1
$17=4
$18=0
$19=0
$20=0
$21=0
$22=1
$23=7
$24=600.000
$25=3000.000
$26=100
$27=3.000
$28=0.100
$29=0.0
$30=1000.
$31=0.
$32=1
$33=1000.000
$34=0.000
$35=0.000
$36=100.000
$37=0
$39=1
$40=1
$41=0
$42=1
$43=1
$44=0
$45=3
$46=0
$56=1.000
$57=1800.000
$58=385.000
$59=6000.000
$60=0
$61=0
$62=0
$63=3
$64=1
$65=0
$100=80.000
$101=80.000
$102=400.000
$110=10200.000
$111=10200.000
$112=1200.000
$120=2200.000
$121=1800.000
$122=2200.000
$130=431.000
$131=952.000
$132=50.000
$259=0
$260=70
$261=0
$262=400
$263=30
$264=0
$265=50
$266=100
$267=0
$268=0
$269=0
$270=5120
ok

1 Like

You have an offset. I’m not sure how to remove this manually so typically need to reset for this to be resolved. Can you run this in Console:

$RST=#

You likely also want to report machine position instead of work position. I believe this is the value you want:

$10=2047

Can you power cycle and then retest?

I have reset numerous times with the same outcome. I will try the other code

I have run $rst=#, #10=2047c and power cycled. There is no change when running $#. I still see HOME:-428.00 -949

Ideally HOME would go to 0,0.

Can you confirm that the machine is homing to the front left of your machine?

If so, I think you could override this behavior but it’s not ideal. Try this:

$10=2046
G10 L2 P1 X-428 Y -949

Power cycle and retest.

That seems to have worked. I tried that but failed to power cycle. But I have now lost my continuous jog. And when I do jog say 200mm on the Y, the machine goes far past 200mm on BOTH X and Y

Annnnnnnnnd back to square one. As soon as I enabled $j it went right back to the same problem

I have to run
G10 L2 P1 X-428 Y -949
after EVERY job or jog.

Can you save your settings and try a full reset? Or have you tried this already?

$RST=*

Make sure that you get a positive acknowledgement that it’s been reset and check $# for offsets.

After saving my settings, running $RST=* I can confirm there are no longer any offsets. HOWEVER (and I should have mentioned this sooner) I still have to for and change $44=3 $45=0 in order for it to home. Once I do that I get the offsets again.

Can you confirm your laser homes to front-left?

If you don’t issue $J does the machine behave properly?

Can you try again and when things revert behavior can you run these commands in Console:

$#
?

I can confirm that the machine homes front left.

I can also confirm that after $rst=*, and laod my saved settings, the machine behaves properly with $j enable and disabled.

Its the moment I change $44=4 to $44=3 and $45=3 to $44=0 that the offsets come back.

Can you reapply the G10 command and retest?

If it fails, what is the output of:

$#
?

$10=2046

ok

$#

[G54:0.000,0.000,0.000]

[G55:0.000,0.000,0.000]

[G56:0.000,0.000,0.000]

[G57:0.000,0.000,0.000]

[G58:0.000,0.000,0.000]

[G59:0.000,0.000,0.000]

[G59.1:0.000,0.000,0.000]

[G59.2:0.000,0.000,0.000]

[G59.3:0.000,0.000,0.000]

[G28:0.000,0.000,0.000]

[G30:0.000,0.000,0.000]

[G59.6:0.000,0.000,0.000]

[G92:0.000,0.000,0.000]

[TLO:0.000]

[PRB:0.000,0.000,0.000:0]

ok

?

<Idle|WPos:0.000,0.000,0.000|Bf:35,7679|FS:0,0|Pn:PX|CL:0,100|PS:2,1|WCO:0.000,0.000,0.000|VA:24592,34|Ov:100,100,100|A:S>

[GC:G1 G54 G17 G21 G90 G94 G49 G98 G50 M5 M9 T0 F15000 S0.]

ok

This is WITHOUT making any chages to $44 or $45, therefore homing fails

Can you reapply the homing fixes, Then run the G10 offset?

Then test and get it to fail as you say. Then run in Console:

$#
?

I’ve left the shop for the night. I will do that in the morning.

sorry for the delay. I had reached my max allowable replies that day.

The following is after $rst=* - reload saved settings - made corrections to $44 and $45 - ran the G10 offset - power cycle - “get position” - $#:

ok

$#

[G54:0.000,0.000,0.000]

[G55:0.000,0.000,0.000]

[G56:0.000,0.000,0.000]

[G57:0.000,0.000,0.000]

[G58:0.000,0.000,0.000]

[G59:0.000,0.000,0.000]

[G59.1:0.000,0.000,0.000]

[G59.2:0.000,0.000,0.000]

[G59.3:0.000,0.000,0.000]

[G28:0.000,0.000,0.000]

[G30:0.000,0.000,0.000]

[G59.6:0.000,0.000,0.000]

[G92:0.000,0.000,0.000]

[HOME:0.000,0.000,0.000:0]

[TLO:0.000]

[PRB:0.000,0.000,0.000:0]

ok

The following is after “home” - “get position” - $#:

ok

$#

[G54:0.000,0.000,0.000]

[G55:0.000,0.000,0.000]

[G56:0.000,0.000,0.000]

[G57:0.000,0.000,0.000]

[G58:0.000,0.000,0.000]

[G59:0.000,0.000,0.000]

[G59.1:0.000,0.000,0.000]

[G59.2:0.000,0.000,0.000]

[G59.3:0.000,0.000,0.000]

[G28:0.000,0.000,0.000]

[G30:0.000,0.000,0.000]

[G59.6:0.000,0.000,0.000]

[G92:0.000,0.000,0.000]

[HOME:-428.000,-949.000,0.000:3]

[TLO:0.000]

[PRB:0.000,0.000,0.000:0]

ok

When do you lose the G54 offset? Or rather what causes it to disappear?

It happens as soon as I home the machine.

I should specify, its AFTER I change $44 and $45. The machine fails to home if I dont change thoes