Machine is inverted since (GRBL) $23=3


(Javier Holodovsky) #1

I like my machine to home left & down ($23=3) and place my origins X0Y0 there so I always work in the positive quadrant.
In GRBL by default the homing switches are to be located on the opposite sides (right & up) $23=0
My problem is that when parameter $23=3, LightBurn will set the maximum machine coordinates where X0Y0 should be.
Is there any tweak or trick for inverting the axes?


(Oz) #2

Just change the origin in the device settings to the other corner.

image


(Javier Holodovsky) #3

Thanks.
The Get Position button will keep acting the same, so will the ‘move to position’
The arrows for manually moving machine axis will invert (inverting cables will fix)
The drawing will invert
…and in the end it worsens.
I’d rather move the switches if soft dosen’t give an answer.
A funnier fix is to turn the whole machine 180 deg.


(Oz) #4

GRBL itself uses negative coordinates by default: https://github.com/grbl/grbl/wiki/Frequently-Asked-Questions#why-is-grbl-in-all-negative-coordinates-after-homing-or-it-so-annoying-and-not-what-im-used-to

If you use the HOMING_FORCE_ORIGIN compile-time option referenced above, then the limit switches become the origin point.

You can also just move the origin with a workspace offset, discussed here: https://github.com/LightBurnSoftware/Documentation/blob/master/CommonGrblSetups.md


(Javier Holodovsky) #5

You’re absolute genius!!!
Thanks OZ