Machine settings not loading - communication with controller failed

Hi I am have an ortur master II. I’ve had it for about a year now.

And I recently did the latest update for LightBurn. My last project was non-rotary and I am doing a rotary now, so I went to machine settings to load my saved rotary settings and there is nothing there. It just says communication with controller failed. So I tried loading the default settings and I cannot not get those back either. I tried re-starting the program, turning the laser on and off, disconnecting from the laser. Nothing seams to work and I cannot load any of my saved settings.

What do I need to do?
Thank you in advance!

Also I am connected by USB and I have checked the connections multiple times, and I am using a Mac. In the move controller on light burn, if I click the arrows nothing happens.

I’ve tried deleting the program, re-downloading it, and re-installing my device onto LightBurn. Still have the same problem.

@Androow Have you tried downgrading to the previously working version of LightBurn? It’s possible that some sort of regression was introduced in the latest version that affects you somehow.

What model of Mac and version of MacOS? Have you recently updated MacOS?

Do you have any other software or another computer to see if you can still connect to the laser? This would help isolate it to an issue with your computer or the laser.

I went to help > Check for updates, and it said, “Your version is up to date 1.0.04” I’m not sure how to downgrade to a previous version.
I’m running macOS Monterey 12.0.1. I’m pretty sure that the project I did last week was after I upgraded the MacOs and LightBurn. It was annoying though because I could only use Absolute cords and not user origin or current position like I could in the past and when I went to LightBurn I followed the tutorial on the website and it wouldn’t work. I had it set up for rotary then switched to regular XY, and couldn’t only use absolute cords.

And only have this computer, and it looks like the software that came with it is only for windows.

Is it possible that you knocked something loose when switching to rotary? Suggest you revisit all your connections to make sure nothing looks off. Is your laser otherwise behaving as you expect? Have you tried reverting back to non-rotary to see if that makes a difference?

As for downgrading, all previous versions of LightBurn are available in Github:
Releases · LightBurnSoftware/deployment · GitHub

1 Like

I’ll try to download one of the old versions. But yes, I checked all the connections and tried non-rotary as well. When I turn the laser on it homes to the front left until it hits the homing switch. SO it’s normal in that aspect, but I can’t get it to do anything when hooked up to my computer.

So apparently I was connected to the wrong device in LightBurn. On the devices tab I select Grill, but on the next option it was on cu.BLTH. I moved it to cu.usbmodem and it works now.
Thank you for you help!

Never mind, it work on non-rotary, but once I clicked enable rotary, then went to machine settings to load my rotary settings, it is blank and once again says communication with controller failed, and I can’t load anything

Update, I restarted the laser and the program and it seems to be working now.

Thank you!

Do I need to turn them off every time I Switch to and from rotary?

1 Like

Great news. Not familiar with your question though.

Thank you for helping me trouble shoot!