Machine settings

It’s any way to load my machine settings from laserweb to lightburn?

Machine settings are stored in the controller itself. Edit > Machine Settings will display them, as will typing $$ in the console and pressing enter. Do you mean different settings?

I have in laserweb 2 different profile… Each with different settings. One setting not burn well… Second setting have more power and I’m not sure why… But I want to take the better setting to lightburn

If there is a way to post the settings you use we can probably help you convert them to LightBurn, but there isn’t a way to load them directly.

I think I know what is my problem… If I do same cut speed and power in laserweb and lightburn then in laserweb Pic is alot better… If I save gcode from lightburn and make it in laserweb it’s still not well but if I take the gcode from laserweb and process it in lightburn then it’s well… Which I believe it’s mean that the problem is in the gcode that lightburn make me

We need to know what your current grbl settings are to offer assistance. :slight_smile:

What version of grbl are you using? Type $$ into the console and then hit ‘Enter’. Copy all results here so we can review and provide additional direction.

You can email GCode from both programs to developer at LightBurnSoftware dot com, with a link to this post so I know what it’s in reference to, and I can tell you what’s different between them.

Email been sent

Two things pop out:

  • The S-parameter range in LightBurn is likely set to 0 to 255, and in LaserWeb it’s 0 to 1000
  • You used an interval of 0.2mm in LaserWeb, and about 0.16mm in LightBurn

The S parameter will be the biggest one - that will make your cuts very light in LightBurn. Go to Edit > Device Settings and change the S-Value Max to 1000.

Lower right in this image:

image

I’m not sure I understand… U think as if I change it to s 1000 and change interval I will get so much better results?

Yes.

If you go to the console and type $$ (enter), your controller will emit the firmware settings. I’m guessing that you have $30 set to 1000, which is what that ‘S-value max’ has to match. It’s the number that controls the range of spindle speeds that LightBurn will emit, and it has to match the value in the $30 parameter of the controller.

If LightBurn is set to 255 and your controller is set to 1000, it means you are only getting about 1/4 of your requested power output. That will be the biggest difference. The interval setting will be less crucial.

Both settings match in lightburn for 255… Only put s 1000 in laserweb

Then LaserWeb is set incorrectly. The $$ setting ($30=255) that gets displayed is coming from your controller. If LaserWeb is set to use 0 to 1000, any value above 255 will just be clamped to full power. If the output from LaserWeb looks better, you likely have an image that is very dim, or something else is wrong.

Can you show a picture of the image you are trying to engrave?

I left the laser power on 255 by machine settings and increased to 1000 by device settings and it’s seems same as laserweb now… Its fine if I did it? Or it’s can harm the laser and controller?

You won’t harm anything, but if you are getting a ‘good’ result by using wildly incorrect settings you’re likely doing something else wrong.

For example, in your file, you are using only 50% power. That means that your S values will be in the output range of 0 to 500, but only 0 to 255 is correct for your controller. Any value higher than 255 will burn at maximum power, so anything in your image that is between 0 (full black) and 127 (50% gray) is burning at the same power level. This is incorrect, and it will affect your ability to get good results.

You should fix your settings, and then figure out how to work with the correct settings - the end result should be better overall.

I just not understand what is wrong by my settings then…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.