Machine sticks on busy / paused after connecting or homing

I have an Ortur Lasermaster 2, and every time after switching it on and trying to send a file, Lightburn reports the machine as busy or paused. I am having to follow this sequence every time to get the machine to work:-

  1. Switch machine off then on
  2. Press Play on Lightburn
  3. Okay the error about being paused or busy
  4. Deselect, then reselect the com port
  5. Press Play again.

At the end of each homing process or file send, Lightburn remains on “Busy” as if it is still trying to stream data

My Ortur Lasermaster 2 also showed busy when first trying with lightburn,i run it 1 time with lasergrbl then went back to lightburn and machine has worked perfect every time since that

Same problem here. Received my LM2 yesterday and wanted to try it today, but the “busy” kicks in whenever it likes. Seems to be random, as I had it after homing but also managed to do one test engraving. I am using OS X, so laserGRBL is no option for me. I thought it was an OS X error, but if the other users have this on windows then we might have to look somewhere else for a solution? Any ideas are welcome!

Greetings Eliaine (tagging @tdgroote for same question)

What job origin are you trying to run at. Absolute coordinates, current location or user origin?

Regards

Seems like opening and closing the USB connection (in the laser window, moving the select menu to (Choose) and then back to (in my case) cu.usbmodem1411 solves the problem most of the time…
Just changed the machine setting so it doesn’t home again on every re-connect so I can continue working more quickly…

@OrturTech: it doesn’t have to do anything with job origin, it is just after connecting to the LM2 that it acts up sometimes, as well as after a job. Looks like the LM2 sends some last command or instruction back to lightburn that is not interpreted well and gets seen as busy status, if that makes sense…

Just a follow-up: machine was connected and “ready”. I tried to jog it to a position in the “move window” and it did not move, but jumped from Ready to Busy. Turning the connection off/on allowed me to move and continue.

This is interesting, need to debug my end. If i may ask what took you to that conclusion?

Is just a guess… the busy status always occurs when something has finished or as said above when you just send a command. As far as I noticed so far it doesn’t appear just out of the blue…
If I can help out by getting some logs or commands out of somewhere please let me know!