Machine zero problem (I think)

I have a Ruida controller. I finally got the camera calibrated. When I try to align the camera, I click frame and the carrier goes all the way to the upper left hand corner and tries to keep going.

What size is the bed of your machine, and what scale is set in the align dialog? (and what version of LightBurn are you running?)

700mm x 500mm, don’t know where the align dialog is( Beta 0.9.04)

This scale:

Though, if your machine is 700 x 500 you’d have to set that pretty large to have an issue. Make sure the machine is set to Absolute Coords before using the camera alignment tool. It’s supposed to set that for you, but it’s possible that is in the upcoming release, and isn’t in the 0.9.04 version.

I tried 100, 75 and 50. Same result on all fronts.

… and you’ve tried setting the software to Absolute Coords before running the alignment wizard? (you have to do this when using the camera)


The system defaults to absolute coords

Have you tried just hitting “Start” and seeing what happens? The frame commands in LightBurn work a little different - they actually send absolute coordinate moves, so it’s very strange to me that it wouldn’t work, but Start just sends a job, and the controller will tell you if that job is out of bounds, so it’s possible it would just work.

Have you recently been using a rotary and forgot to disable the rotary axis, by chance?

I haven’t tried to start the job, I’ll try that. No rotary, this is my first time using the software.

When I start the job, the carrier goes straight left and then it is out of bounds.

This is very strange. Have you run a normal job with the software before?

When I first got it loaded, I ran an image. It worked then, but I can’t use the camera without calibrating.

Yes, I get that, I’m just trying to figure out if a normal job worked. There’s really no difference between a normal job and the camera alignment job. The camera alignment uses the size you’ve entered for the workspace to center the work. Is your workspace size set to 700 x 500mm?

yes. under device settings

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.