Mapping Hotkeys not working

Hi guys,

I have a USB gaming controller connected to my computer which works perfectly. I am trying to map the jog functionality to the D-pad. The edit hotkeys interface recognises the button press fine, but then provides the message as shown in the screenshot below. It then proceeds to blank out the key selection and thus the hotkey doesn’t work.

Can you please shed some light on what this error message means? I’ve also tried this with another custom built HID keyboard, trying to map the key ‘F14’ to ‘Frame’ function. The exact same thing occurs - it detects the ‘F14’ keypress, then proceeds to tell me the message in the screenshot, and clears the ‘F14’ out of the hotkey textbox.

Thank you in advance

Right uses an un-modified character key – perhaps you can check out the source code and see what causes this message to occur, and see if there’s some type of workaround or fix.

Not certain but seems to me you can’t use unmodified keys as shortcuts. Modifiers would be keys like control and alt.

Great, thank you. I’ve solved this problem now by modifying the controller driver and adding a CTRL modifier to every SendInput. So I can now control my laser with an Xbox One controller :slight_smile: Now Id like to see a hotkey option for laser fire, such that pulse testing etc can also be done via my controller.