Material Thickness Z Height before Moving

Hi, When I tell Lightburn that my material thickness is 3mm it will move to the job first then raise by 3mm. I have air assist with a pipe so would like it to raise to 3mm before moving. How do I acheave this?

Also when it returns to zero after a Job how do I get it to also go to the z height of zero (currently it is staying at the 3mm)

You can add a Z axis command in the GCode section of the Device Settings.

G1 Z3

Will move the head to 3mm above zero. Light burn will know it’s done it and not move it another 3mm once it has moved. You could take it higher and then Lightburn will move it back down to 3mm once in position.

Hi Paul,

Thank you for your reply but I don’t think that answers either of my questions?

I have the ‘Enable Z axis’ fuction acive. It dose chnge the Z height t the correct height (no matter what the Z height is before I press start)

But I would like to know

  1. I want it to go to Z3 before it moves in the X or Y direction (Currently it is doing it after X & Y)

  2. How to return it to Z 0 automatically after completing a job. Currently it will return to Z 0 & Y 0, but in this example Z will still be at 3mm

Z Axis Controls Device Settings - LightBurn Software Documentation

Putting the command in as I suggested in the Start GCode section of Device settings will issue the command before Lightburn starts the burn. That will raise the head 3mm before any x or y movement.

If you want to return it to zero after the burn add commands to the End GCode section to reposition the head where you want

Can you tell me if any of my setting are wrong? I have read thought his section and can’t see the answer to my problems either.

Thank you for your time in trying to help me :slight_smile:

Okay yea so I am happy I put:

G1 Z20 F3000 S0
in ‘Start GCode’


G1 X0 Y0 F3000 S0
G1 Z0 F3000 S0
in ‘End GCode’

Thats a good enough work around for me :smiley:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.