Maybe a daft question

Hi All
I finished using my rotary on my OLM3 and then couldn’t understand why things weren’t working properly, turns out one of the things wrong was I hadn’t selected Absolute coordinates. I’ve got two macro’s in lightburn console, one for rotary set-up and one for normal use. Is it possible to input G90 into this macro? do I just type G90 or is there a double dollar code + G90.

Cheers Geoff

The G90 command will be included in the GCode LightBurn produces when you’ve selected Absolute Coordinates as the Start From mode, so there is no reason to create a macro to send that command.

However, when working with a rotary is generally not advisable to work in Absolute Coordinates — Current Position is preferred. Position your laser over the object on your rotary, select the appropriate Job Origin depending on whether you want output centered under the laser, to its left or right, and start the job.

See our documentation here for more information on how these settings work:

If you can share more about what was going wrong in your process, and how you arrived that the conclusion that using Absolute Coordinates was the solution, we should be able to give more direct guidance

Hi Tyler
What I’m trying to achieve(hoping) by adding G90 into the macro is that it turns on absolute Coordinates if I forget after using the rotary.
Just to clear up a point you made I was using current position with the rotary, but had forgot to select Absolute Coordinates when going back to normal use, which is why I’d like to put G90 into the macro.
Hope that makes sense.

Ah, ok, thank you for the clarification. Unfortunately creating that macro wouldn’t help — the G90 command needs to be in the beginning of the GCode LightBurn creates for your project. If you’re using Current Position, the GCode will begin with a G91 (relative positioning) command, which would override the command you sent using the macro.

If you’re concerned about remembering to turn on Absolute Coords again, the best option may be to go to Edit > Device Settings and toggle on Enable Job Checklist. Click the Edit button next to the toggle, and write a reminder message for yourself to check that you’re using Absolute Coords if not in rotary mode.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.