Measurements in mm

Hi All,
I have a wierd set up, where all my settings are set in mm, but i have to use Cm to get what I am after. If i was to set my bed size to 500mm by 400mm then my laser will keep going out of bounds, so I have set it for 50mmx40mm and it works fine. Also my speed is at 120 etc, where I think it should be at 1200.
I have a diode Laser with unbranded set up

Many Thanks

Hi Alan
You did not say what controller you are running. But it sounds like you have not got your machine setup correctly. Specifically Travel resolution or “Steps per mm” it sounds like you are off by a factor of 10. If you are running GRBL the parameter numbers are $100 for X and $101 for Y.
But there is no point in going into great detail how to fix it until we know what you are running.
Please let us know


Ahh Yes sorry my bad,
Yes I am running GRBL, I will check my $$ to see what they are set up to.


$100,$101,$102 should be set to 80, not 800. That is why you are having the 10:1 ratio issue.
Type $100=80 in the console and press enter. Repeat for $101 and $102

Super, I will give that a try in a bit, as I am running something atm.

also, i swapped my laser to the other side of the X axis, now when I move the laser i have to use the opposite buttons, also it inverts my image, do you know what I need to change to get it back right again please??

Hi Alan
It looks like Anthony got you pointed in the right direction on travel resolution.

For direction for X it is Parameter $3 If it is 1 change it to 0 or vis versa.

You can also do it from
Machine settings
and in “output settings” look for “X direction pin invert” and change it from true to false or vis versa


1 Like

Thank you guys for sorting that out. All works perfectly now.

Just got to change all my Cm into mm. :grinning:

For some reason $3 was on =2. but have put on =1 and now goes the right way.

Cant Thank you guys enough.


Hi Guys,

so it sorted the invert out and the stepss/mm which was suggested above. However im getting lot of weird other things happening. the movement speed is really slow, the laser seems to slow down alot before it hits the end and the laser takes a sec before coming back on and gradullay too.

I have entered the list of my $$




































Many Thanks

Read here:

Your maximum speed is 500 mm/minute, or about 8.3 mm/sec. ($110 & $111)

Your acceleration is set to 10 mm/sec^2 which is really slow - you likely want that to be somewhere in the range of 500 to 3000. ($120 & $121)

Your machine size is set to 200 mm x 200 mm, which is probably also incorrect. It looks like all your GRBL settings are just the GRBL defaults, so you’ll need to adjust them for your machine.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.