Messed up the controller settings while trying to install rotary

Hi members. I am running an Atomstack X20 Pro and I tried to install the rotary to do glasses. I was following a guy on Youtube and I have completly messed up the controller settings. My laser isn’t framing or firing and keeps bashing against the rails. Is there a factory reset on the machine? I need to start again as I have done something very wrong.

I dont think its the machine. I think your settings in Lightburn are not correct.

First thing to do is remove the rotary. And plug the connector back into the Y axis Then go to Laser Tools > Rotary Setup and disable the rotary. On the main screen under “Laser” make sure the Start From: is set to Absolute Coordinates. Then restart the machine and open lightburn and home the machine and see if it homes correctly. Let me know what the results are.



Thank you. Tomorrow I will do as you have advised and let you know. I just did not get there today :upside_down_face:

Remember too
in console you can apply
command to reset your firmware to its defaults if you been changing settings there

Thank you, that worked!

Now I will try to get the rotary to work.

Great. Now go back and restart and home your machine. Then hook up the rotary and set the Start From: to Current Position. Go to Tools Rotary Setup and enable the rotary. Set it for Roller or Chuck whichever your using. Then you need to set the mm Per rotation and the Circumfrence of your Tumbler. What Rotary are you using.

Here’s a full description of the process:
Plug your rotary into the cable from the mother board to the Y axis motor
Check your settings in Laser Tools Rotary Setup
Make sure rotary is set to Chuck if thats what you have
Enter your setting in mm per rotation. Mine is 165 but yours may be different
Then do a test.
The rotary should move in one direction then the opposite direction
And it should end up where it started.
I use a sharpie to put a mark on the rotary top center to see where it started
It should end up in the same place as it started
Then enter the circumference of your mug.
Set your start from to “Current Position”
Then manually move the laser head to the start point and do a frame.
Adjust as necessary until you get the frame in the correct position

Here’s a video of the whole process:

1 Like

Thank you, :blush:, it worked :muscle: I did my first glass and it came out well. I just need to play with the engraving settings to get it more visible, but I am so stoked!!

Thank you for your patience and time, I really appreciate it.

1 Like

I set power to 40% and Speed to 600 mm for glass

1 Like