Microsoft Lifecam HD defaulting to 640x480

I recently paid for another subscription as I saw the camera system was changed to use Windows cameras at full resolution. I’m noticing Lightburn is still defaulting to 640x480. How can I change this? Ive tried Windows 9 and Windows 10. The camera on both of those PC’s in other applications work in HD, just not Lightburn. In Settings Camera Resolution has the Highest radio button greyed out but not accessible. Ive tried changeing Camera Capture System from Default to Custom with no luck also.

Same here. lower resolution in lightburn regardless of usb cable length, even when camera is connected directly to pc without extension. i am not yet using a camera as i haven’t yet mounted it and i am considering a fixed focus stick camera. this is just one of my octopi camera which i tested for laser use. nothing more than that.

ice_screenshot_20200802-091039 ice_screenshot_20200802-090958

It’s because you’re using the ‘Default’ capture system instead of the ‘Custom’ one. The default system is the one provided by our cross-platform framework, and is very limited. The Custom one is what we wrote specifically for Windows (8 and higher), and it should give you access to the full resolution of the camera.

In my case, I did try custom mode and restarting lb but i did not get an image right away. in order to see the camera stream i needed to switch few times from None > camera and back for the stream to start (and get to see the high res). Not every time i launch LB i am able to open this camera view. this window refuses to open at times and only restart fix that. In default mode however - every time i launch LB streams works like it should.

In custom mode window loads blank

In my case I tried Custom, closed the software and opened it again and checked that it was in Custom mode. Still no luck. Any ideas OZ?
I did note in the release notes it said you could change resolution of the camera, but I cannot find that option anywhere.

You can’t, but LightBurn can. We automatically choose the highest resolution presented by the camera.

Do this:

  • Run LightBurn. If you aren’t in ‘Custom’ mode, choose that.
  • Select ‘None’ for the camera
  • Go to Help > Enable debug logging
  • Select your camera
  • Wait a moment for it to cycle and try to start
  • Quit

You’ll find a file called LightBurnLog.txt in your documents folder. Attach it here and I can have a look.

Here’s mine:

12:24:55.836 D: “LightBurn 0.9.16” “Mon Aug 3 2020”
12:24:58.717 D: “Microsoft® LifeCam Cinema™” “\\?\usb#vid_045e&pid_075d&mi_00#6&100d8a86&0&0000#{e5323777-f976-4f5b-9b55-b94699c46e44}\global”
12:25:00.023 D: -----------------------------------------------
12:25:00.023 D: Select Camera
12:28:28.475 D: “LightBurn 0.9.16” “Mon Aug 3 2020”
12:28:30.069 D: “Microsoft® LifeCam Cinema™” “\\?\usb#vid_045e&pid_075d&mi_00#6&100d8a86&0&0000#{e5323777-f976-4f5b-9b55-b94699c46e44}\global”
12:28:31.146 D: -----------------------------------------------
12:28:31.146 D: Select Camera
12:28:31.146 D: -----------------------------------------------
12:28:31.177 D: Format: 35 1280 x 720 @ 30 fps
12:28:31.177 D: “enumControls getProcParam 2 failed - Element not found.”
12:28:31.177 D: “enumControls getProcParam 5 failed - Element not found.”
12:28:31.177 D: “enumControls getProcParam 6 failed - Element not found.”
12:28:31.193 D: “enumControls getProcParam 9 failed - Element not found.”
12:28:31.193 D: “enumControls getCamControl 12 failed - Element not found.”
12:28:31.193 D: “enumControls getCamControl 15 failed - Element not found.”
12:28:31.193 D: 11
12:28:35.415 D: Clipboard data present:
12:28:35.415 D: (“text/plain”)
12:28:36.305 D: Align output unchecked
12:28:36.305 D: EV: 1018 took 7 uS
12:28:36.306 D: EV: 1013 took 244 uS
12:28:36.307 D: EV: 1018 took 6 uS
12:28:36.307 D: EV: 1009 took 1765 uS

All of that is normal (and very similar to what I see with my own camera when I run it)

I did find a single bug in the new camera library today, but it would cause a crash, not a simple failure.

Strange as it seem, I wasn’t able to reproduce this issue where the camera stream did not work. i did however managed to get the camera window to stuck on the upper left corner without being able to move it, not before enlarging it from the bottom right corner for it to detach and could then be dragged around and dock it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.