Migration from LaserWeb: Homing, Gcode Macros

smoothieware

(Chris Harrison) #1

I’m hoping to transition from LaserWeb to Lightburn (Chinese blue and white 4060, Cohesion 3D running Smoothieware, connected via USB). There are a couple of things that I’m having trouble with though, and which don’t seem to be covered in the documentation:

  1. My machine homes to Y-max rather than Y-min; the home position being 0,400 but the origin is still 0,0 at the front left. My Smoothieware configuration knows about this, and G28 homes it as expected. When I clicked the “Home” button in Lightburn though, it sets off towards 0,0. Any ideas?

  2. In LaserWeb there exists the ability to configure custom Gcode snippets to run before and after jobs; I use this to enable my extractor fan etc. before starting a job, and to pause for a while before turning the fan off upon job completion. Is it possible to do something similar in Lightburn?

Thanks.


(Ray Webster) #2

I have the same machine, same setup (lightburn) but not the same issue. mine home to the X0, Y400. Make sure you picked the Cohesion smoothie when choosing. I don’t know that it will make a difference, but there are 2

On the C3D board, there is a place to plug in for the extractor fan, Lightburn automatically puts the M codes in to turn on and off as needed.
see here https://forum.cohesion3d.com/t/laserboard-air-assist-control/101

Ray


(Oz) #3

LightBurn just issues G28.2 XY for homing on Smoothie. What command did LaserWeb issue? As far as I know, the homing directions are configured by editing the config file, and have nothing to do with LightBurn - my Smoothie board homes to X0 Y200 (rear left) but the origin is 0,0 (front left).

For GCode pre/post, there isn’t an option for this yet. You can set macros, but there is a plan to add pre/post gcode snips before too long.


(Chris Harrison) #4

Thanks for your reply. Using the console in LightBurn:

  • G28.2 sends my machine to 0,0.
  • G28 sends it to 0,400. G28 is what I have configured for homing in LaserWeb.

Based on the relevant Smoothieware config, I checked my config.txt file on the C3D to see if I had grbl_mode enabled; it’s not mentioned at all, meaning that G28 has the Reprap meaning of “seek the endstops for each axis, stop once they are found and this position is now the origin for the machine”.

Is there a way to change the Gcode used to home my machine?

EDIT: The following are listed as supported Gcodes by Smoothieware:

G28 Home The given axis, or if no axis specified home all axis at the same time (edge) NOTE in CNC/grbl mode this is move to park position, use $H to home G28
G28.1 Set Predefined Position - This position will be returned to by G28.2 G28.1
G28.2 Move to Predefined Position - This perform a rapid move to the Predefined position set by G28.1 (in grbl mode this will do a home)

(Ray Kholodovsky) #6

You need the CNC build of Smoothie - this is where G28.2 command homes it.

I don’t know if you’ve deviated from the C3D provided firmware builds or if we shipped some very early Mini boards with regular smoothie firmware, but the things you are asking about are hardcoded in LightBurn so you’ll have to make some adjustments.

The latest C3D provided firmware and config files for your board will be a good start.

We don’t ever enable grbl mode in smoothie btw.


(Chris Harrison) #7

It turns out that somewhere along the line, I updated my board with a non-CNC build of Smoothieware. With the CNC build flashed, LightBurn works as expected. As an added bonus, I found your default config file for your current LaserBoard controller and was able to update some of my apparently very conservative acceleration and max speed values.

Thanks very much for your help.


(Ray Kholodovsky) #8

I’m assuming you have a Mini. The LaserBoard files should work mostly fine… pins are the same, maybe need to invert the direction pins? Idk.

The batch 3 mini files are located at the bottom of the mini install guide linked at Cohesion3D.com/start

May want to compare those.

Worth noting that you should keep the config and firmware files with each other. LaserBoard has a newer firmware build that may not play nice with older config files if any syntax changed.

If you want to run grbl-lpc, you’ll need a build specific for your board and setup.