MillRight MegaV w/ JTECH 7W Pro not Jogging correctly

I am having issues with my machine not jogging to the correct position when I use LightBurn with my Mega V. It homes correctly front left ( looking at the machine). When I try to “set laser position on the program after homing it crashes to the opposite corner. I set up the machine as 885mmx885mm (just under the 35"x35” of the work area), set it up as GRBL, and origin bottom left on the “Device settings for GRBL”. I am using LightBurn 1.3.01. The machine jogs correctly on Universal G-Code Sender. How do I fix this problem so I can position the laser head at the desired position?

Thank you,


Assuming our Mega Vs are identical, the settings you mention are same as mine except for the dimensions, I use X890 Y785 due to fixtures I have in front within the work area. The XY homing switches should be back left corner of machine, and machine zero back right corner. Thus, G54 WCS should be set to machine coords X-885 Y-885 in your case. Please verify that.

I also define grbl config to a machine work area 1mm larger (XY) than LB is told that it is, so that maximum distance moves in LB keep the machine off the homing switches which will throw an annoying error even when hard limits are disable.

I often make the mistake, when launching LB, of leaving my machine in a G54 WCS zero that was somewhere convenient in the work area when doing a previous CNC process such as routing or plasma, because its usually convenient for those process toolpaths to be WCS zero on a corner of the work material. That was a tough concept for me to overcome when I began using LB; LB is designed around having free range of the entire work area due to the way it has programmed “continuous” jogging and out of bounds warnings at least. So to solve the forgetfulness, I wrote a LB macro to define a friendly G54 WCS:
G10 L2 P1 X-890 Y-786 Z-5 A-1080

So if you don’t like working in Absolute Coords, LB gives you the option to use Current Position (only G91 relative mode) or User Origin (combo of both G90 and G91 modes). With Current Position mode, you could have a WCS zero other than front left corner, however continuous jogging (GRBL-M4 device) will throw an error, you’ll have to use dimensional jogging only.

I hope I got all that right, please post if you still have trouble.

Oops, upon a re-read, I see you mention homing is front left, no problem. Machine zero should still be back right, and G54 WCS same as I mention.

Hey Lou, thank you for your assistance in this. I do prefer to work in Absolute Coordinates. I was jogging the machine around using the “Move” window, and found that the machine Homes to X: -896.35 Y:-845.5 Z:-5 which would explain it crashing to the far right corner when I click " Go to Origin". How do I reset the Home to be X:0 Y:0 Z:0? My Machine coordinate is set to X=885 Y=885. The grid square/dimension also appear to be correct on the program window itself 885mmx885mm. In regards to the G-Code do I put the “G10 L2 P1 X-885 Y-885 Z-5 A-1080” in my console? Also what is the “A-1080” command?

Let’s reset the approach for a moment. Please post the console results of $i, $$, $# and $g commands. And please post the screen shot of Edit->Device Settings window.
Oops, Edit-Device Settings window.

“A” axis is rotary, you don’t need it if no rotary is attached, I had just cut and pasted the entire command from my macro.

So here are the console results:

Waiting for connection…
[VER:1.1i MegaV 4 Axis Router.20190120:]
Target buffer size found
[VER:1.1i MegaV 4 Axis Router.20190120:]
Target buffer size found
[GC:G0 G54 G17 G21 G90 G94 M5 M9 T0 F0 S0]

I tried looking them up, but what are the $i, $$, $# and $g commands?

I do have a rotary, but its not hooked up and can be a problem for another time lol.

@Fsntasy and I chatted on the phone about various things LB, MillRight Mega V, grbl, and gcode related.
I shared with him these good references to gcode and grbl info-
Grbl v1.1 Configuration · gnea/grbl Wiki · GitHub
Grbl v1.1 Commands · gnea/grbl Wiki · GitHub
LinuxCNC "G-Code" Quick Reference

As for immediate fix to setup LB, he’ll use the gcode command which LB recommends for operating in a negative workspace, in his case setting G54 WCS zero such as…
G10 L2 P1 X-885 Y-885 Z-5
and perhaps assign it as a macro so he can set it when using LB, having switched from using other gcode senders and CAD/CAM systems with his CNC while working in another process such as milling, routing, or plasma.

He’s also changing $20=1 (soft limits on) and $21=0 (hard limits off), and we talked about some of the LB Device Setting switches that are convenient to use with MR Mega V.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.