Missing line when cutting overlapping objects

I am cutting many items and they are overlapping to save time. Paths are mostly fine. In some parts randomly a line is missing. This happend more than once to me.
Does anyone know how to avoid the issue?

image
image
1x1_.lbrn2 (296,9 KB)

they seem to be there for me, except they come last in order of cutting You might want to try some optimization parameters
image

The trick with optimisation parameters works. It is just a bit frustrating. Now I have to check every time manually all the lines are there. I don’t know why it dosen’t work with default settings?

IT does work if you let it finish but some lines are done at very last

making sure you “think” the design in optimization while building the graphics and the LBRN makes all sense and will save you so much pain in future. so i would highly recomend it (plus is fun to try to beat the defaults :P)

No. This is the finished result, I let it run untill the end. I had to cut it out by knife or scrap the parts multiple times by now. I think it is a bug, not a feature.