Mks dlc 32 v 2.1

I need a little help here !!! PLEASE !! A problems as follows:
#1 is that I downloaded the driver, (ch340) for my MKS Controller. (zip file). The mks instructions say - open file and click on “drvsetup64.exe”. There is no .exe file to click on. It shows “drvsetup64” and “setup”. Which one am I to click on?
Thank you

It’s probably drvsetup64. Do you have file extensions enabled in file explorer? If not you won’t see the .exe part of the filename. Try enabling file extensions by the folowing

In file explorer, click on “View” and choose “Show” from the dropdown and then click on “File Name Extensions” .

Hello Tim: dvr64 did nothing and setup became setup.exe. I opened it and the install / uninstall window opened with the file ready to install. I click install and get “driver install failure” I’m reading the help section now. And thank you.

Man it’s frustrating when the instructions don’t work as published.

Just a thought, as I’ve done this myself, did you unzip the file before trying to do the install? An exe file won’t work if the zip file isn’t unzipped.

Perhaps get the driver from the link in Lightburn documentation.

Where did you download that driver? It’s not MKS-specific, just google it and download it anywhere. Maybe another version works. You can also use LaserGRBL, it includes this driver and you can install it from the tools menu.

1 Like

I went to mks’s own web site for the down loads. Early this morning digging around more in the MKS site. I found one place where it says you have to install the INF file before you install the ch340 driver. (Oh, yes I did un-Z the file.) AND then I found another spot in the MKS that says to uninstall the INF file and install ch340.exe. Nothing works. My pc can’t see the controller, LB can’t see the or find the controller. Oh, and any time I power up the mks, the stupid laser fan starts blowing and you can’t turn it off. Right now my personal thoughts on MKS is less than dirt!! After reading, (sorry Melvin), I’m not an IT person nor do I know programming and I could care less about IT garbage and programming… Laser garbage says you can install the driver right from the tools menu. There we go again, more garbage to install! I’m giving to crap one more night of jacking with it and then I’m ripping it all out I have 3 Orturs and I have already started pulling one of ortur controllers out and plan on putting it in the console and trash that mks junk. At least with the ortur, I don’t have to install or program anything, just hook it up and go to work. I also found and downloaded/ printed off the 19 page mks user manual and the 13 page firmware update manual as well as the 14 page wiring manual as well. Nothing they say works!!
Sorry for my ranting but I’m POed at this junk. It has to go!!!

Sorry to step in.
Remove .txt please.
CH341SER-WINDOWS.rar.txt (534.7 KB)
After you install the drivers connect your laser and add your laser to Lightburn and then select the correct com port in the dropdown menu.

I have tried that, LB can’t even find my device. I power up my pc, power up the mks.
I click find my device in LB, it comes back blank, can;t find it.

So you have to add it manually.

I have that same controller. Lightburn won’t find it automatically. You need to manually create the device then select it from the laser window. Does Windows make a connection sound when you power on the laser, or a disconnect sound when you turn it off? If so Windows is seeing it, we just need to get Lightburn to see it.

I’ll walk you through how I did mine. In lightburn Laser tab click devices, then create manually, choose GRBL, just plain GRBL not one of the other options with a suffix, Choose Serial/USB, Name you machine whatever you want and define the work area (mine is 410x410), select which corner it homes at and I recommend turning off auto home for now, click finish. In the Laser tab, with your machine turned on, select your new device from the drop down menu next to the devices button. After a few seconds you should see ready in the top of the Laser tab.

You will then need to go into the console and set up your controller for your machine. Chances are it will not be correct out of the box.

If you’ve already set it up manually and it’s not connecting then this is above my knowledge level.

I just downloaded laserG. followed directions. under tools - I clicked install ch340 then another window pops up and says install the inf file, I did that and the same thing comes back as mks, driver install failure. what now?


tim: read closely. A dear friend of mine who passed about a year was a super pc guru. Back in May of 21, (when I joined LB) Joe open my version of LB. and looked at all the programming lines. I remember about a few lines down from the top was a command line that said something about “repeat”. Joe removed, (deleted) that one line and now I can install my old version LB into any and as many pcs I want. I never told anyone about my LB being modified… With that being said, I have one two year old Dell laptop, one nine year old HP laptop, my new mini Lenovo thinkcenter and my old faithful Beast that Joe built for me July of 2005. we call it the beast because of large size, and weighing in at 52 pounds. (this is the pc I’m right now) 20 years old and this thing has NEVER given me one bit of trouble to date. So – I have the May 2021 version of LB installed in all my pcs. The Beast, and the HP are 32bit and are running windows 7pro and the Dell has windows 10 pro in it, and the new Lenovo is 64 bit and it came with 10pro already loaded in it… I have no problem running any of my little ortur lasers with any of my old pcs. only having problem with lenovo and MKS. I tried to install mks in the beast and it does the same thing, driver install failure. Yes, all my lasers are usb. Yes I get the dialogue box. First thing it shows is install of the inf file. I click install, successful install, next pops up install for the driver
and that fails every time, (driver install failure). It does the same thing with my old beast and the new lenovo. I have even uninstalled every thing and then reinstall, no luck there either. I have a slew of links for mks and when I go to get info, I keep getting “error 404”. I tried to go to the mks download tool and get the same thing, error 404. So I don’t know now. Ripping out mks and installing an ortur controller is looking better every minute.

Let’s back up and get some basic info. What version of windows are you running? Is it 32 or 64 bit? Which Lightburn?
I see from your profile you have other lasers, are they working properly and do they connect via USB?
If they were working, do they still work after trying to install the CH340?

When you try to install the CH340 are you presented with a dialogue box with buttons for install and uninstall? If so try to install again, then when that box comes up, choose uninstall. After that finishes try install again.

Another idea that just hit me. Use the uninstall for CH340 then reboot. Go to the Setup file, right click it and choose “Run as Administrator”. Worth a shot.

I have a DLC32 V2.1 also… Lightburn finds my device, no issues… First is an CNC3018, second is the DLC32… The last is the fiber…

Lightburn calls your os to connect or query devices.

If the os can’t see the device, Lightburn will have no hope of seeing it either.

When any program gives you an error message… it’s probably not good.

I can scan my usb inputs on Ubuntu, you’ll have to figure it out yourself in windows.

jack@Kilo:~$ lsusb
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 25a7:fa67  
Bus 001 Device 003: ID 062a:4102 MosArt Semiconductor Corp. 
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 004: ID 9588:9899 BJJCZ USBLMCV4
Bus 003 Device 003: ID 056a:0011 Wacom Co., Ltd ET-0405A [Graphire2 (4x5)]
Bus 003 Device 005: ID 1a86:7523 QinHeng Electronics HL-340 USB-Serial adapter
Bus 003 Device 002: ID 1a86:7523 QinHeng Electronics HL-340 USB-Serial adapter
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

It’s the QinHeng boards… they need the hl340 interface.

I’m sure someone here can help you look at your devices… from the os.

This is one of the reasons I dumped Windows decades ago… - IMHO: Windows = :face_vomiting:

Good luck…


Ok – this is weird big time. Again I plugged into the beast pc, opened LB and guess what !! Even though it says driver install failure I “CAN” move the laser in x or y dir.
When I run find my laser, it comes back blank. I did a manual create and install grbl and LB still cannot find the controller. But, (now) I can move X & Y and I can fire the laser although I have to hit the stop button to turn the laser itself off. Sorry, I just made a burn spot on my new pretty base board!!

I believe CH340/HL340 regarding drivers are the same.
Maybe your drivers are already installed and in use by some software and windows prevents the installation.
Try restart Windows and then only start Lightburn, do not run any other program that can use the laser.

Make sure you’re using the latest driver for OS compatibility. Most companies that use the CH340 chipsets are distributing drivers that are years or decades out of date. The current drivers and debugging software are available direct from the chip manufacturer

The Manufacturer’s website is found at Press the Magnifying Glass and search for CH340, and it’ll pull up everything that is CURRENT.

There are about a dozen different chips in the series that all use the same driver, with A-H revisions.

The physical chip is a CH340 but using lsusb shows up as

QinHeng Electronics HL-340 USB-Serial adapter


That doesn’t matter. They use the same driver for all the 340, 341, and 380 series chips.

QinHeng Electronics is the WCH-IC website, so please make sure you have their latest driver direct from their website.

There are driver versions being distributed by laser manufacturers that wont even detect in current versions of windows, let alone operate properly.

1 Like