More help with Focus Test

I was trying to assign values similar to what was shown in this the above thread “Z-5 to Z+5 or Z-10 to Z+10” but lightburn will not let me assign negative values to either of the inputs.

Am I using is wrong? I have not been able to find any info on the Focus Test function at all anywhere in the documentation, is there a reference I am missing?

You generally move to the lowest Z range you want to test, then use positive numbers to go up from there. It doesn’t allow negative numbers because if you’re using absolute coords that’s a head crash.

ok, I have been using “current position” for everything because it seems like no matter how I have things configured it never goes where I expect it to unless using current position. I do have home switches, I am using this on an X-Carve with a 3w laser. I have followed all the instructions for creating macros, etc… and just cant seem to get it function correctly. Sometimes it moves the wrong axis completely like if i tell it to go up 10mm it will go left 10mm, and if I then try to manually move it right it still goes left. When it gets like that I have to completely turn of the X-Controller and restart and rehome to get it to move in the right direction. Just gets all confused for some reason.

The latest version of LightBurn will self-configure for an X-carve, including making the macros for you. If you just delete your X-Carve from the devices list and re-do the ‘Find my Laser’ process, it’ll set up for you.

That said, as long as you home the machine then click ‘Use Laser’ when you run LightBurn, that should set everything properly.

Ok I will give it a try, although I did just set this up this past Wednesday for my X-Carve and used the wizard and it could not find my X-Controler but I was able to set it up manually using the Grbl profile and it does connect and work. Is this something that has been updated since then?

I will go back and try the Find My Laser too and see if that provides different results.
Thanks for the info and I will post the results.

I hasn’t changed, no. Make sure that nothing else is running that might be talking to the laser, and that you don’t have another profile in LightBurn that would be talking to it either.

Ok I went back and deleted everything I manually set up. My X-Carve is connected to the PC and is on Comport 12 in device manager, no other comports are listed.

As soon as I run lightburn it wants me to setup the controller, I click Find My Laser and it always says shows a dialog with nothing found in it. I have rebooted. Verifted all other profiles are deleted.

Is there anything else I can do? Not sure why its not detecting my X-Controller. It has 1.1f on it and works when manually configured and the Comport12 is selected in the dropdown on the main screen.

I couldn’t say. Do this:

  • In LightBurn, go to Help > Enable Debug logging (at the bottom of the help menu)
  • Try the find my laser process again, starting with no lasers in your list
  • Quit

You should find a file called ‘LightBurnLog.txt’ in your documents folder. Attach that here.

Ok, I enabled debugging log and here is the log. Looks like its sees it on Com2 which is where it is although it says probable Ruida, which its not. This is a windows 7 workstation if it matters. Log attached.LightBurnLog.txt (3.4 KB)

I think the automatic search isn’t expecting to see GCode devices using an authentic FTDI USB converter, because so many of them don’t use that. I’ll tweak it to check for gcode too.

Ok, that wasn’t actually installed initially I don’t think. Installed that thinking that might be the issue and found a troubleshooting document on the Inventables support site and it recommended to install it. But I trying the FIND both ways and got the same result. I can uninstall it and run the log again and see if its a different result. I will send an updated log with the driver uninstalled.

I removed the FTDI driver from the system and when I did and rebooted then the X-Controller showed up in the device manager as an other devices. Attached is the log from Lightburn also after the driver had been removed. As you can see in the log it is not recognized at all now.

I then clicked the update driver in device manager for the X-Controller as seen in the picture and Windows searched the net and automatically installed a FTDI driver which made it show up as USB Serial Port (COM5).
I then ran Lightburn again and it still did not detect the X-Controller. Although I can still add it manually.

Devicemanager_X-Controller LightBurnLog.txt (1.7 KB)


That device (FTDI) is what the X-Controller is using to talk to the PC, so you can’t remove the driver. I just have to make LightBurn allow for the fact that some GCode devices will use that chip when I’m auto-searching.

Ok, I understand. Any idea how soon that update might be released?
When I removed the GRBL profile it also removed all my macro’s which I wasnt expecting and I didnt have a back up and dont remember where I got all the commands I had in there for Use Laser and Use CNC.

Probably within a couple weeks, but the only thing you’re missing is the auto setup. If manual setup is working, you’re not gaining much.

ok I will dig back through the forums and figure out what I put togther for the macro’s. I didnt realize it was going to remove those to.

The macros will be:
Use Laser:
G10 L2 P1 X-750 Y-750 (the 750’s here will be the width and height of your laser work area)

Use CNC:
$10= (whatever it is by default, possibly 1 or 115)
G10 L2 P1 X0 Y0

Awesome, thanks. That helps a lot. Could you recommend how to offset the laser from the center of the spindle? It seems that I cannot get the laser to actually go to the location like 100,100 cause its always off by the offset of the laser and I end up with the center of the spindle at 100,100. I tried subtracting the offset from the y -750 but it didnt seem to make a difference.

That should actually work - If you make that line G10 L2 P1 X-750 Y-650 (I’m assuming it was 750 to start with) that should push the laser forward by 100mm.

Thats what I thought to, but I dont think it worked for some reason. I will go back and change it again and test it out. Thanks.