Move ctrl and shift not working

The arrows in Lightburn work to move the laser head and z-axis, but ctrl or shift click doesn’t change the move distance, also “Distance” just to the right is greyed out. Anyone know a fix or workaround to get finer movement? Using a Ruida 644XS.

You have “Continuous Jogging” enabled if the distance field isn’t enabled. That means it’s jogging for as long as you hold the button, not a fixed step size.

1 Like

Thanks Oz, that fixed it but has now seemed to cause another problem; it’s like Lightburn no longer knows the axis limits, and so will try to overextend making all kinds of nasty noises. Also now at laser startup (my pc off) the z-axis just goes up and up, I did previously enable relative z moves, but at this point the laser isn’t even connected to my pc/Lightburn. Very strange

That sounds like a wiring issue, or you have homing enabled for the Z axis but don’t have it configured properly, or something along those lines. If you power the machine and it says 10,000x and 10,000y for the location, the homing cycle didn’t work, so the machine has no idea where it is or where the limits are.

Any idea why the Z axis is only moving in one direction?

Yep spot on! The x and y values were 10,000, resetting from the controller worked to resolve the head trying to move beyond the frame and got proper values (u is still 10,000 though), however now the bed can only move down. Refocusing doesn’t help to get the bed to move up.

Your Z limit switch is likely shorted, or mis-wired. If the controller thinks the auto-focus sensor / switch is triggered, it will not let you move the material closer to the laser.

I think I had the focus pen screwed too tight, simply rescrewing it a bit lighter meant the bed could now come up.

Thanks a lot for the help, I’ve only been learning about this stuff for a couple weeks and I gotta say I’m super impressed with the software and how active and transparent you are on here, will be buying for sure!