Move/Origin/GRBL Issues

Hello,
I just started testing the software and like it and think of buying it.

But now I’m trying to use it directly with my GRBL-Controller and it does not work as expected.
I use a GRBL_V1.1-Setup which works perfectly with LaserGRBL and UGS.
There are many issues with Lightburn which are kind of difficult to describe.
A simple example:

  • I do Homing
  • I move to my user zero position
  • I press “Set origin”
  • I press “Go to origin”
  • It moves to somewhere else… I would expect, that it does not move anywhere as I just set the origin

When I just save the gcode and run it with the two mentioned programs everything works fine. I even compiled a positive-GRBL-Version as I thought it would solve the problem, but it does not.
Another problem is that when I stop a program and restart it. Lightburn moves my gantry to somewhere else but not the zeropoint.
Print and cut does not work either… Maybe these problems are related to the first mentioned.

The console output of the above written actions (first mentioned problem) are:
Waiting for connection…

Waiting for connection…

Grbl 1.1hdm [’$’ for help]

[MSG:’$H’|’$X’ to unlock]

ok

[MSG:Caution: Unlocked]

ok

[VER:1.1hdm.20210315:]

[OPT:VZ,15,128]

Target buffer size found

ok

ok

<Idle|MPos:0.000,0.000,0.000|FS:0,0|WCO:53.793,67.113,-9.469>

ok

<Idle|MPos:0.000,0.000,0.000|FS:0,0|Ov:100,100,100>

ok

Starting stream

[MSG:Pgm End]

Stream completed in 0:00

<Idle|MPos:0.000,19.998,0.000|FS:0,0|WCO:53.793,67.113,-9.469>

ok

Starting stream

[MSG:Pgm End]

Stream completed in 0:00

<Idle|MPos:0.000,40.001,0.000|FS:0,0|WCO:53.793,67.113,-9.469>

ok

Starting stream

[MSG:Pgm End]

Stream completed in 0:00

<Idle|MPos:0.000,59.999,0.000|FS:0,0|WCO:53.793,67.113,-9.469>

ok

Starting stream

[MSG:Pgm End]

Stream completed in 0:00

<Idle|MPos:0.000,80.001,0.000|FS:0,0|WCO:53.793,67.113,-9.469>

ok

Starting stream

[MSG:Pgm End]

Stream completed in 0:00

<Idle|MPos:0.000,100.000,0.000|FS:0,0|WCO:53.793,67.113,-9.469>

ok

Starting stream

[MSG:Pgm End]

Stream completed in 0:00

<Idle|MPos:0.000,119.999,0.000|FS:0,0|WCO:53.793,67.113,-9.469>

ok

Starting stream

[MSG:Pgm End]

Stream completed in 0:00

<Idle|MPos:19.998,119.999,0.000|FS:0,0|WCO:53.793,67.113,-9.469>

ok

Starting stream

[MSG:Pgm End]

Stream completed in 0:00

<Idle|MPos:40.001,119.999,0.000|FS:0,0|WCO:53.793,67.113,-9.469>

ok

Starting stream

[MSG:Pgm End]

Stream completed in 0:00

<Idle|MPos:59.999,119.999,0.000|FS:0,0|WCO:53.793,67.113,-9.469>

ok

ok

<Idle|MPos:59.999,119.999,0.000|FS:0,0|Ov:100,100,100>

ok

ok

Starting stream

[MSG:Pgm End]

Stream completed in 0:01

Kind regards,
Dan

You have a WCO (workspace coordinate offset) programmed, and your machine is reporting positions in machine space, not work space. Type $10=0 in the console so when LightBurn asks the machine “Where are you?” it gets the correct answer.

https://lightburnsoftware.github.io/NewDocs/CommonGrblSetups.html

That was lightning fast. Thank you :slight_smile:
Unfortunately it still does not work.

  • I home
  • I press “set origin”
  • I press “goto origin”
  • it moves

My outputs:
Waiting for connection…

Grbl 1.1hdm [’$’ for help]

[MSG:’$H’|’$X’ to unlock]

[MSG:Caution: Unlocked]

ok

[VER:1.1hdm.20210315:]

[OPT:VZ,15,128]

Target buffer size found

ok

$0=10 $1=25 $2=0 $3=2 $4=0 $5=1 $6=0 $10=0 $11=0.010 $12=0.002 $13=0 $20=0 $21=1 $22=1 $23=3 $24=25.000 $25=800.000 $26=50 $27=2.000 $30=1000 $31=0 $32=1 $100=266.670 $101=266.670 $102=266.670 $110=2700.000 $111=2700.000 $112=2700.000 $120=160.000 $121=160.000 $122=80.000 $130=1000.000 $131=482.000 $132=200.000 ok -------------------- Console-Output after I set $10=0 and tried it again: ok <Idle|WPos:-53.793,-67.113,9.469|FS:0,0|WCO:53.793,67.113,-9.469> ok ok <Idle|WPos:-53.793,-67.113,9.469|FS:0,0|Ov:100,100,100> ok ok <Idle|WPos:-53.793,-67.113,9.469|FS:0,0> ok <Idle|WPos:-53.793,-67.113,9.469|FS:0,0> ok ok Starting stream [MSG:Pgm End] Stream completed in 0:01

You might need to nuke the workspace offset - its keeping that even after homing, and that is the issue it seems. Type:

G10 L2 P1 X0 Y0 Z0

In the console - that will force the offset to all zeros.

1 Like

That did the trick!
Thank you very much for your fast help!

I now try the other mentioned problems, maybe they are gone as well.
Thanks again.

Dan

I’m having exact same problems. Thanks Oz for the link to Grbl settings doc. In a day or two I should have it going!