Move window coordinates

Hello all,

I modified my Neje Master 2S Max to longer legs, and changed the size in the machine parameters. Changed 460mm to 1510mm. The machine’s origin is in the bottom left corner.

However, even after restarting the software, the “Move” window still shows X: 0 Y: 460 when the laser is at top left corner instead of X: 0 Y: 1510.

Meaning that when laser runs down 460mm it shows Y: 0, then it shows negative values until Y: 1050.

That is weird but also an issue because I can’t enter negative values in the fields below when I want to move the laser …

Where should I change the setting for this window ?

Thanks !

That’s not what I would have expected but it’s possible the firmware is hard-coded for the coordinates after homing.

You may be able to get it to behave by using a work offset. Run these commands in Console:

$10=0
G10 L2 P1 X0 Y-1050

Then rehome and test. Is home now 0,1510?