MPCNC machine and Lightburn issues

I converted a spare 3D printer to a laser engraver. I’m running an SKR Pro 1.2, TMC 2225s, Atomstack 5A 20w (PWM), with modified MPCNC Marlin firmware and LB 0.9.24. My laser PWM is conncted to PC9. This is my first laser and I’ve only worked with Marlin with my 4 3D printers. I’m using Windows 8 Enterprise 64 bit OS.

There are a few rabbits that I’ve been chasing for the last few days that I’m confident are not machine issues. I’ve searched the forum with varies key words and nothing is turning up, maybe I’m searching the wrong topics. I am able to control the printer and run burn jobs, but there are rabbits running around.

  1. When LB scanned my machine, it detected a GRBL-M3 (1.1e or earlier), I thought it was odd because it’s Marlin firmware. When I tried to edit the settings to Marlin, the Machine doesn’t respond. So I changed it back to GRBL-M3. Does LB automatically default Marlin as GRBL?

  2. When I go into Machine Setting, I get only get “Communication with Controller Failed”. I read in another thread that if I turn LB off and then back on it should correct that. It didn’t work for me. I closed out LB with the machine on and the other way around.

  3. I am getting inconsistent layers and missing layers. The layers consist of 3 rectangles and text in the center of the smallest rectangle. The rectangles are centered inside of each other, largest to smallest. I home the machine before every burn and reset the origin, frame out the layer with the laser on, go back to origin and start the burn. Everything looks good until I start the burn. The framed layer burns exactly as it should, but the text layer, that is centered in the first layer, can be off by a few centimeters or just burn a straight line. Recently everything is centered but I’m missing 2 layers, the outside layer burns and the text does too, but the layers in between do not.