Multi-camera bug


(Clifton Gurlen) #1

This is a continuation of 2 Cameras, One PC

Our makerspace has a single PC that drives 2 Redsail x700’s - which Lightburn does well. We wanted to add cameras for the two cutters, however, Lightburn does not deal with maintaining calibration, etc with one camera and multiple cutters.

Any chance this will get fixed?

cliff
MidsouthMakers


(Ben) #2

I think it would be vastly easier for the makerspace to have 2 PCs than to change code to work with 2 cutters. And it’s such an edge case that I’d be hard pressed to think it could possibly be worth the trouble.

Then again, I’m not involved in any way, but there are other wishlist items I’d much rather be adopted.


(Rick James) #3

Just in case you are not aware,


(Oz) #4

LightBurn stores the camera calibration data in the device profile, so with two lasers, if they were called different things, and connected via Ethernet, the camera calibration data would be distinct.

There is an issue at the moment where the cameras are selected by name, not by unique ID, so it will always pick the first camera with a given name, meaning two “LightBurn” cameras won’t let you choose between them.


(Clifton Gurlen) #6

The code already works with 2 cutters - just trying to get the camera stuff worked out.


(Clifton Gurlen) #7

This may very well be our problem - both cameras are the same. Even changing the device name in Windows (in the registry) did not change the name in Lightburn.

Do you know what USB device parameter Lightburn pulls the ‘name’?

cliff


(B Sollis) #8

This behavior matches what I have seen. The calibration data remains tied to each laser, but since we can only use one camera at a time, calibration for the second laser doesn’t do us much good. We have had to resort to leaving our second camera unplugged so that it doesn’t trip up Lightburn. I agree that an ideal solution would be to have the cameras tied to our machine setups, so that when “Laser 1” is selected, then “Camera 1” is automatically used, and when “Laser 2” is selected then “Camera 2” is automatically used.

But if I am understanding you right, this won’t be possible with the current way the cameras are selected. We have tried re-naming the cameras in device manager, but Lightburn does not recognize the new names. Does anyone have suggestions or tips for what I can try next?

Thanks!
-Brant


(Oz) #9

I’ll look to see if I can find a unique ID of some kind that I can use to match the cameras instead of using just the name, but it’ll take some time. We’re moving to the other coast at the end of this month, so development will be impacted a bit.